8 Replies Latest reply on Oct 7, 2009 4:28 PM by Ted Moens

    Blaze Data Service Problem

    Ted Moens

      Greetings:

       

      I have a functioning BlazeDS/Tomcat server running on my Windows Vista machine (turnkey).  I have succcessfully run all the examples. Editing the demos works fine too.

       

      In a new project (or when editing an existing one) I try to import a BlaseDS/LCDS Service.  I am asked for an RDS password. No idea on this. So I click no passwrd required and press next.

       

      An error appears on the service import screen:

       

      "Unable to accesss RDS server.Go to C:/XP Program FIles/BlazeDS/tomcat/webapps/samplesWEB-INF/web.xml and uncomment RDS servlet"

       

      Ok, I go to the file and there is no RDS servlet stuff to uncomment.  After a bit of searching, I find some posts which all point to including the following code in my web.xml file:

       


          <servlet>
              <servlet-name>RDSDispatchServlet</servlet-name>
              <display-name>RDSDispatchServlet</display-name>
              <servlet-class>flex.rds.server.servlet.FrontEndServlet</servlet-class>
              <init-param>
                  <param-name>useAppserverSecurity</param-name>
                  <param-value>false</param-value>
              </init-param>      
              <load-on-startup>10</load-on-startup>
          </servlet>

       

          <servlet-mapping id="RDS_DISPATCH_MAPPING">
              <servlet-name>RDSDispatchServlet</servlet-name>
              <url-pattern>/CFIDE/main/ide.cfm</url-pattern>
          </servlet-mapping>

       

      One of the posts emphasized  <param-value>false</param-value> indicating that I probably should not see the a password request.  Edit complete.  Restart Tomcat.  Restart Flashbuilder.  Behaviours are identical, i.e. password requested followed by same error message.

       

      Can anyone help me pinpoint my error?

       

      Ted

        • 1. Re: Blaze Data Service Problem
          Mayank (Adobe) Adobe Employee

          Which version of blazeds are you using?

          • 2. Re: Blaze Data Service Problem
            Ted Moens Level 1

            Just Downloaded this morning: blazeds-turnkey-3.2.0.3978.zip

             

            Ted

            • 3. Re: Blaze Data Service Problem
              mjonkman Level 1

              Hi Ted

               

              Open the Web xml file for the service. (WEB-INF\web.xml)

               

              If the RDS section is commented out, uncomment it so it looks like this:

               

               

               

              The turnkey has that set to true (or at least the standalone version has that), change it to false.

               

              Restart Tomcat and you should be good to go.

               

              Now its wholly possible that the install you have is corrupt in some other way, but the above should get you going.

               

              I've been working with BlazeDS binaries that I installed on my existing Tomcat 6 server with Flash Builder 4 for the last month with no problems - HOWEVER it was a pain in the butt to get going initially. I downloaded the stable build and it was completely hosed - wasted a day trying to configure it with Flash Builder 4. I finally downloaded one of the latest nightly builds and it worked like a charm.

               

              Sincerely

              Mark R. Jonkman

              • 4. Re: Blaze Data Service Problem
                Ted Moens Level 1

                Hi Mark:

                 

                Could you please include the bit about what it should look like? My guess is that it will be the same as I have above.  Also I already noted the true/false point in the original post - was what I said wrong? Would you please look at the original post and see if what I presented looks right?

                 

                I may well try a newer BlazeDS.

                 

                Thanks,

                 

                Ted

                • 5. Re: Blaze Data Service Problem
                  mjonkman Level 1

                  Hi Ted

                   

                  Sorry, I didn't read the original message, me bad!

                   

                  Okay, I think I see your problem. First if you are trying to connect up to BlazeDS in FlashBuilder 4 and you plan on using the Data/Services panel then you need to have BlazeDS 4.x, you said in one of your emails you were using 3.x

                   

                  Next, do NOT attempt to use 4.0.0.7548 Beta 1 Build dated June 5, 2009 at least it didn't work for me.

                  http://opensource.adobe.com/wiki/display/blazeds/downloadblazedstrunk

                   

                  Now I should qualify that statement. It might work with the Flash Builder 4 Beta 1 release, however I could not get it to work for me (don't ask).

                   

                  I've been using blazeds-bin-4.0.0.10240 successfully for the last 3 weeks.

                   

                  Sincerely

                  Mark R. Jonkman

                  1 person found this helpful
                  • 6. Re: Blaze Data Service Problem
                    Mayank (Adobe) Adobe Employee

                    I would recommend using the 4.x builds of blazeds for dcd workflows.

                    • 7. Re: Blaze Data Service Problem
                      Ted Moens Level 1

                      Thank you both.

                       

                      I will try for 4.x BlazeDS

                       

                      Ted

                      • 8. Re: Blaze Data Service Problem
                        Ted Moens Level 1

                        HI Mark:

                         

                        I have tried 4.0.0.10240 as you suggested.  Now I get a little further.  FB can see the service destinations on the BlazeDS side correctly.  However when I try to make a service from one of them, Flexbuilder is not showing anny of the calls available for that service.  Any ideas?

                         

                        Ted