6 Replies Latest reply on Oct 29, 2009 1:46 PM by Miceal Zimmer

    Canon HF10 and Premiere Elements 8

    klaxon_hunter07

      Hello!

       

      I have a Canon Vixia HF 10 that I am trying to use with the Adobe 8 Premiere Elements trial. When I click the "AVCHD or other hard disk/memory camcorder" option in the Get Media tab, my camera is not recognized as an import source. It is recognized by the ImageMixer capture software, and I am able to import those clips from my computer into Premiere.

       

      I have read other posts talking about this issue in version 7, and it doesn't seem to have been fixed in version 8. Any plans for this anytime soon?

       

      Also, because I'm using the trial--what's the deal with the watermark? It seems to appear only when I modify the files in certain ways, such as changing the opacity of a clip or adding an effect, for example. Why...?

       

      -Sarah

        • 1. Re: Canon HF10 and Premiere Elements 8
          the_wine_snob Level 9

          Welcome to the forum.

           

          Any plans for this anytime soon?

           

          Unfortunately, this is a User-to-User forum. There is no Adobe presence, beyond that red A logo at the upper-left of the forum page.

           

          Also, because I'm using the trial--what's the deal with the watermark?

           

          That is the limitation of the trial. In PrPro, all things MPEG are disabled. There is nothing (that I know of) disabled in PrE trail, but it does watermark the output. Here is the FAQ Article on removing the watermark, once one acquires the full version.

           

          As far as your camera, you will need to copy your material to the computer's HDD and Import that, rather than Capture, which would be used for miniDV tape cameras.

           

          Good luck,

           

          Hunt

          • 2. Re: Canon HF10 and Premiere Elements 8
            Steve Grisetti Adobe Community Professional

            I have no idea why your Get Media/AVCHD downloader isn't working. It absolutely should, if your hardware is properly hooked up, your system is tuned and up to date and your Premiere Elements project is using the proper project settings. So there's really nothing to "fix".

            • 3. Re: Canon HF10 and Premiere Elements 8
              Beltane72 Level 1

              I have the same problem with my Canon HF200.  Fortunately, this one only has external flash cards, so I just put the card directly into my card reader and imported the movie from that.

               

              I've still not been able to figure out why it cannot import directly from the camera.

              • 4. Re: Canon HF10 and Premiere Elements 8
                the_wine_snob Level 9

                With some flash memory camera/cards one does have direct Import. With others, one must Copy the files and Import from the HDD.

                 

                I am not sure about your particular camera, but others will likely know it, and can give you complete instructions on how best to get the files to the computer.

                 

                Good luck,

                 

                Hunt

                • 5. Re: Canon HF10 and Premiere Elements 8
                  Lurkah

                  I have this HF200 unit and importing stuff is really the least of the problems. As indicated elsewhere the whole 1080i AVCHD support is essentially broken. Unless you're able to put up with extrodinarily bad deinterlacing or Canon's blur-o-matic 25p setting.

                   

                  Can only assume that it's all work in progress. I was a hair from laying down cash before giving the demo a spin, pretty lucky escape. Oh well, PE9 perhaps?

                  • 6. Re: Canon HF10 and Premiere Elements 8
                    Miceal Zimmer Level 1

                    I have the same problem in 8.0 so you're not alone.