0 Replies Latest reply on Oct 5, 2009 8:32 AM by suleimankh

    Could not delete ... May be locked by another process.

    suleimankh

      hi all,, i am new user for glassfish + hslqdb + flash !!

      brief definition my problem is
      ****all the change i do it stay in a cache buffered and not passed to the db (hsqldb.jar) for some reason


      Details:


      1) i tried to search for the answer of my problem every were i couldn't find the answer.. so just in case if i am opening a thread that already answered i am sorry

      2) i build a project that use glassfish as server and hslqdb as standalone (embedded) database using flash builder 4 beta.

      3) *** the PROBLEM i am facing is : when i run my program the insertion finish with no error, and then i read it and the select is finished with no error, but the problem after that if i insert and read again.. it will just read the new data.. the old data disappear, and even when i close the program i try to go to \WEB-INF\lib and run my hslqdb.jar.. the table is still empty !!!

      i also get this msg
      Could not delete C:\glassfishv3-prelude\glassfish\domains\domain1\eclipseApps\test_prjct\WebContent\WEB-IN F\lib\test_prjct.jar. May be locked by another process.



      i think i cant upgrade my data base bcz glassfisg lock the files!!
      bcz when i open the .script file for the hsqldb i find the insert statement i just did !

      Pleas help