5 Replies Latest reply on Oct 7, 2009 1:20 PM by jay fresno

    Taming table styles and cell styles

    jay fresno Level 2

      I find table styles and cell styles to be quite a nightmare in InDesign -- that is, as long as the paragraph style is included in the definition of the cell style. The only way I've been able to get a table without overrides involves so many steps that it is not efficient:

      1) Click in an empty paragraph.

      2) Apply the paragraph style.

      3) Type the text that will eventually go into a table cell. (All of my tables are one cell, one column tables).

      4) Select the text without selecting the paragraph symbol at the end.

      5) Choose Table > Convert Text to Table.


      I'd greatly appreciate it if anyone knows of a script that can do these steps and can put me out of my misery.

      (Or perhaps there is some way to avoid the cell style overrides that I just haven't discovered. There is a discussion about this problem at http://forums.adobe.com/message/2043634#2043634, but none of the suggestions got rid of the paragraph style cell overrides.)

        • 1. Re: Taming table styles and cell styles
          jay fresno Level 2

          Is there no efficient solution for this ? -- if anyone has any suggestions for avoiding paragraph style overrides in table cells, please help.

          • 2. Re: Taming table styles and cell styles
            G. Singelmann Level 3


            for one I fail to see what your question has to do with scripting. Perhapas the others are confused by this, too and thus don't know how to answer.


            Also I can't reproduce the problem. When I just checked and created a table with table- and cell- and paragraph styles, everything worked fine without overrides.

            Perhaps your paragraph containing the table has overrides to start with?


            You would fare better in any case if you asked this in the indesign forum.

            • 3. Re: Taming table styles and cell styles
              jay fresno Level 2

              Thanks for taking the time to reply to my question. I wish you had been able to reproduce the problem because it keeps happening repeatedly with my InDesign tables, and is very time-consuming to fix.


              When a table has paragraph overrides (which is every time a table is inserted, in my case), I don't even get a "+" showing next to that paragraph style and Alt/Option or Shift-clicking doesn't fix the override.


              I posted in the scripting forum because I though someone might be able to suggest a script that would speed up table formatting and automatically remove overrides. I'll take your suggestion and post in the InDesign forum.

              • 4. Re: Taming table styles and cell styles
                RalphBentley Level 1

                Hi jay


                You should check the character styles. If the paragraph styles won't over ride, I have found it's because there is a character style applied. Some people use character styles to format paragraphs. (?!)



                • 5. Re: Taming table styles and cell styles
                  jay fresno Level 2



                  There was indeed a character style applied, which was in a nested style. I've now gotten rid of the little monster.  Y a y !