0 Replies Latest reply on Oct 7, 2009 1:19 AM by luke3design!!

    Socket error #2031 on shared ip hosting

    luke3design!! Level 1

      Hi to All !!

       

      Some weeks ago I wrote a post about the socket error #2031.

       

      I developed an application using the amazing maliboo's FTP library for flex. On the previous server I had all worked fine, but when  the hosting company switched on a new server things started get worse.

      I got the company switch back to ProFTPD from PureFTP but still doesn't work.

      While banging my head on the desk I achieved that the new hosting is based on a shared ip system while the previuos one was a dedicated ip system.

       

      In the application I can perform well the FTP login and change directory, but when I try to switch to passive mode on the port told by the server, the app tries to establish the connection for some seconds and return the #2031 socket error.

       

      Some ideas?Some workaround?

      Someone is experiencing the same issue?

      Thanks in advance!!!!

       

      Bye Luca!