3 Replies Latest reply on Oct 12, 2009 4:03 AM by Bhakti Pingale

    CF Builder B2 Remote Server Configuration

    bbqman63

      Hello,

       

      I'm trying to setup a remote server under CF Builder B2 per http://help.adobe.com/en_US/ColdFusionBuilder/Using/WS0ef8c004658c1089-38317734121cdfd5fd3 -7fff.html.  My intent is to setup remote debugging to a JBOSS 4.2.3 EAR deployment of CFUSION 9 instance (which is running fine).

       

      I have a clean installation of Eclipse (Galileo 3.5.1 SR1) with a "plugin installation" of CF Builder B2.

       

      RDS configuration for the remote server is tested and working fine (RDS configuration test function and access to remote services, file system and data sources are all succesful).

       

      The problem is I'm not able to complete the server setup under the "Servers view" according to the referenced documentation.  Specifically, when selecting the New -> Server option from the Servers view context menu, there is no "ColdFusion" option under the available server types.  Per the instructions:

      Specify the remote server settings in ColdFusion Builder

      In the Servers view, do one of the following:

      • Right-click and select Add Server.

      • Click . Select ColdFusion and click OK in the Add Server dialog box.

       

      The "Add Server" option is not available, but I suspect this is just an Eclipse version issue.  In any case, this is what I see when selecting New -> Server:

       

      server1.jpg

       

       

      There is no option to add a "ColdFusion" server.  Additionally, as soon as I replace "localhost" in the "Server's Host Name" field, all of the available servers disappear except "Basic -> HTTP Server".

       

      servers.jpg

       

      Am I missing step or doing something else wrong?  Advice?

       

      Thanks,

      Dave

        • 1. Re: CF Builder B2 Remote Server Configuration
          bbqman63 Level 1

          Update: Downgrading from Eclipse 3.5.1 (Galileo) to 3.4.2 (Ganymede) seems to have fixed the issue with not being able to create a ColdFusion server.  The installation instructions for B2 explicitly state that 3.4 is required....strange since B1 seemed to work fine with 3.5.x, but B2 doesn't...  *scratches head*.  It might be a good idea to indicate the 3.5 doesn't work since a version specificatoin is often inferred to mean a minimum version.  It's also possible I missed something with the 3.5.2 config, but 3.4 is working..sort of....

           

          My RDS configuration still seems to work, except I can no longer use the "Services Browser" view--which I could do prior to down-grading.  Expanding the server in "Services Browser" view displays "Unable to get meta data for cfc" message.  RDS File and data source browsing still work.

           

          Also, the "Servers" view status for the remote JBOSS server is perpetually "STOPPED"... it's not, I can browse the CF site via URL (there's no option to start a non-JRUN server from the IDE, anyway).  It's not clear which configuration Builder is using to determine the remote server status, so I'm not sure where to look.

           

          I've enabled debugging on the JBOSS side and followed the remote server setup on the Builder side. The firewall on the server is allowing incoming for 8080, 8787 (JBOSS JVM debug port, which is also configured in CFIDE..), and 1099 (JBOSS JNDI port); although there doesn't seem to be a Builder configuration for a Naming Service for non-JRUN configs in Builder, so I'm not sure if the latter is relevant.

           

          Bottom line is that I'm still not able to use the "Services Browser" or remote debugging.

           

          Any help is appreciated.

           

          Thanks!

          Dave

          • 2. Re: CF Builder B2 Remote Server Configuration
            bbqman63 Level 1

            I was able to get Eclipse 3.5 working with Builder B2 as a "plugin installation", but I'm still not able to use "Browse Services" or remote debugging (server shows "stopped") with JBOSS 4.2.3.  Any help is appreciated if someone has had success in getting this to work.

            • 3. Re: CF Builder B2 Remote Server Configuration
              Bhakti Pingale

              Hi Dave,

               

              You need to specify the same port on which your CFIDE is running in the server settings.

               

              Can you send us the screen- shot of the remote server settings?

               

              -Bhakti