6 Replies Latest reply on Oct 8, 2009 10:54 AM by kingquattro

    tons of error when opening .as

    kingquattro Level 1

      I am not sure if its just me, but is been bugging me since beta 1.  Every time I open a .as file, I get loads of syntax errors, when I shouldn't get any

      Things along the lines of "missing ;" or "expected ) before" etc...  Also I don't get any code assist either.  If I close the file, and restart Eclipse all errors are gone. Has anyone else run into this?

       

      UPDATE: Just noticed then when I open a .as file its being opend as CF JS file.

       

      My setup is

       

      Eclipse 3.4.2

      FB beta 2 as eclipse plugin

      CFB beta 2 as eclipse plugin

       

      Thanks

      Jay

        • 1. Re: tons of error when opening .as
          Rob Brambley Level 1

          Hi Jay,

           

          This is very strange. I have a couple questions for you:

           

          1) When you say this happens after you open an .as file, do you mean that you only see it when the .as file is open?  The Flex compiler should show errors as long as you have instantiated the class, regardless of whether the file is open. Are you seeing this in the problems panel or within the code editor?

           

          2) You say you have CF Builder installed.  Is there any chance that you've run with only FB installed?  If so, do you see the same results?  What perspective are you using when this happens?

           

          3) Can you attach your error log?

           

           

          Thanks,

          Rob Brambley

          Computer Scientist, Flash Builder

          • 2. Re: tons of error when opening .as
            kingquattro Level 1

            Robert,

                    I see the errors only in Problem panel, not in the editor itself.  If I launch Eclipse, and then I open a .as file, I will see all the errors in problem panel, when I try to run Flex project, I get a pop up saying I have some error and if still want to proceed.  But if I close the .as file, and restart Eclipse all errors are cleared.  So I guess in a given session if a .as file is open I will get these errors, and they persist until I close the file and restart Eclipse

             

                 I am get this, when in Flash/Flash debug perspective.

             

                 I will test by uninstalling CFB and see if that make any difference.  Just running uninstaller for CFB should do right?

             

            Jay

            • 3. Re: tons of error when opening .as
              Rob Brambley Level 1

              Well, now that I see the update on your original post, it looks like the CF plug-in is contributing these errors. You probably want to right click on the AS file and choose Open With > ActionScript Editor (you may have to look in Other...) to use our AS Editor.

               

              -Rob

              • 4. Re: tons of error when opening .as
                kingquattro Level 1

                Thanks Robert that did the trick, I went ahead and changed the file association as well Eclipse as well

                • 5. Re: tons of error when opening .as
                  Rob Brambley Level 1

                  I just spent some time trying to reproduce this and I definitely was able to.  However, it doesn't look like the JS editor was associated with .as by default, so I'm curious if that was the case for you...?

                   

                  Also, could you tell me what your installation steps were?  For example, this is what I did:

                   

                  1) Installed Flash Builder Beta 2 Plug-in using the bundled eclipse.

                  2) Installed Cold Fusion Builder Beta 2 into the eclipse-host-distro folder of the FB installation.

                   

                  Did you install in a different order? CF first?

                   

                  Thanks,

                  Rob

                  • 6. Re: tons of error when opening .as
                    kingquattro Level 1

                    Hey Rob,

                       Yes the order of install is correct, but not bundled Eclipse, I already had an install of Eclipse 3.4.2.

                     

                    Jaysheel