4 Replies Latest reply on Oct 20, 2009 2:10 PM by python79

    components not correctly displayed in design screen

    python79

      Hi,

      since Flash Builder 4 Beta 2 I have the problem that components are not fully displayed in the design view. I did not specify a background color so everything is white, but the weird thing is that of some of the components only edges are visible, while some components become only visible when selected (e.g. the datagrid on the attached screenshot).

       

      Any comments on this?

       

      Thx

        • 1. Re: components not correctly displayed in design screen
          Tanya Dimalsky (adobe)

          Hi python79,

          could you please post the files you are having problems with (component files)?

          thanks!

          • 2. Re: components not correctly displayed in design screen
            python79 Level 1

            Hi Tanya,

             

            only one component is exhibiting this problem, all the other components are visualised correct in design view. I have reduced the code of this component considerably but the problem is still there!

             

            See attachment for code.

             

            wolfgang

            • 3. Re: components not correctly displayed in design screen
              python79 Level 1

              attachment should be included now :-)

              • 4. Re: components not correctly displayed in design screen
                python79 Level 1

                okay, when attaching files I get...

                There was an error, please check below
                It appears you're not allowed to view what you requested. You might contact your administrator if you think this is a mistake.
                so let's do it the classical way
                <?xml version="1.0" encoding="utf-8"?>
                <s:Group xmlns:fx="http://ns.adobe.com/mxml/2009" xmlns:s="library://ns.adobe.com/flex/spark"
                xmlns:mx="library://ns.adobe.com/flex/halo"
                xmlns:v="views.*" xmlns:ev="events.*"
                width="100%" height="100%"  xmlns:tboffersservice="services.tboffersservice.*">
                <s:layout>
                  <s:BasicLayout/>
                </s:layout>
                <fx:Script>
                  <![CDATA[
                   import mx.events.ListEvent;
                   import mx.events.FlexEvent;
                   import mx.collections.ArrayCollection;
                   import mx.controls.Alert;
                            import mx.rpc.AsyncResponder;  
                  
                   [Bindable]
                   public var selectedCategory:String = "%";  
                   [Bindable]
                   public var selectedPriceCategory:Number = 10000;  
                 
                  
                   protected function dataGrid_creationCompleteHandler(event:FlexEvent):void
                   {
                    getTb_offersByTypeResult.token = tboffersService.getTb_offersByType(selectedCategory, selectedPriceCategory);
                   }
                  ]]>
                </fx:Script>

                <fx:Declarations>
                  <s:CallResponder id="getAllTb_offersResult"/>
                  <tboffersservice:TboffersService id="tboffersService" fault="Alert.show(event.fault.faultString + '\n' + event.fault.faultDetail)" showBusyCursor="true"/>
                  <s:CallResponder id="getTb_offersByTypeResult"/>
                 
                </fx:Declarations>


                <mx:VDividedBox height="720" width="360" x="0" y="60">
                  <mx:DataGrid x="482" y="100" width="350" height="200" minHeight="100" id="dg1" editable="false" draggableColumns="false" creationComplete="dataGrid_creationCompleteHandler(event)" dataProvider="{getTb_offersByTypeResult.lastResult}">
                   <mx:columns>
                    <mx:DataGridColumn headerText="ID" backgroundColor="#F8F1E7" dataField="ID" visible="true" editable="false"/>
                    <mx:DataGridColumn headerText="a" dataField="a" visible="false" editable="false"/>
                   </mx:columns>
                  </mx:DataGrid> 
                 
                  <mx:Form width="350" height="100" minHeight="100" backgroundColor="#F8F1E7">

                   <mx:FormHeading label="Detailinfos"/>

                   <mx:FormItem label="a" width="305">
                    <s:TextInput id="sdetail" text="{dg1.selectedItem.a}" editable="false" width="239"/>
                   </mx:FormItem>
                        
                         <mx:Label id="myInfo" width="100%" color="0x00FF00" textAlign="center" />
                 
                  </mx:Form>
                    
                </mx:VDividedBox>

                <s:DataGroup x="765" y="524" width="200"/>

                </s:Group>