2 Replies Latest reply on Oct 11, 2009 7:19 PM by Mayank (Adobe)

    Deploying with Zend Framework

    rootsical

      Hi there.  Just trying to see if my flex application could be deployed on my host server but having a bit of trouble with data services.

       

      Firstly I am using, locally, Wampserver 2.0 with php version 5.2.9 and Flex 4 plug-in for Zend Studio 7.  The Flex 4 SDK is nightly build 10945.  ZendFramework is version 1.9.2.

      As for the host server, it is Bluehost with php 5.2.9.  Again ZendFramework, I uploaded version 1.9.2.

       

      When I run data services locally I can access remote mysql database no problem.  Only thing, it feels like flash builder is forcing me to install Zend Framework in my actual project folder not on my actual server root.  No problem, I let it install then changed the gateway.php and amf_config.ini files accordingly to refer to the Zend Framework which is placed at serverroot/library/ZendFramework192/library .  My project is placed at serverroot/public_html/projectfolder .  As I said, locally, no problem, I can delete the ZendFramework installed in the project folder and there is no problem, it refers to the new location I give it.

       

      When I try deploying online, however,  I get a "channel disconnected" fault string when trying to access the same data.  I did change my endpoint on the service to go to the gateway.php absolute url when uploaded.  I also changed the amf_config.ini and gateway.php to refer to the location of the ZendFramework on the server, namely, serverroot/library/ZendFramework192/library.  No luck.

       

      I am no expert so I don't know what is wrong.

       

      I have tried a host of solutions.  If I navigate to the url of gateway.php I have some versions where it asks to download a file and some versions where it echoes Zend Amf Endpoint.  Which is the one I want?  Either way, the service doesn't work though.

       

      Could it be a host server problem, do I need a php.ini file to locate my ZendFramework, do I need a xml permissions file or something?

       

      Or is it likely I've messed up in trying to get the folder structure right (although I've checked, changed and rechecked loads).  Any suggestions would be much appreciated.  Like I said, locally it worked like a dream...

       

      Thanks a lot!