9 Replies Latest reply on Oct 14, 2009 12:56 PM by MaritimeGirl

    Index Tab Be Gone! (How?)

    MaritimeGirl

      I thought I had the sneaky way of doing this - by entering garbage on the window definition in Advanced Properties beside "Index:"  This hid the Index tab and I thought all was well but I was wrong.  It's fine until I do my on-the-fly topic swapping and then it goes crazy on me - see http://forums.adobe.com/thread/504223?tstart=0

       

      Now, I figured out that that problem goes away IF I take out the garbage from the Advanced Properties, but of course my Index tab reappears.  I don't want it.  I have a custom button that is called Index that points to a topic which is our handmade Index.  Having both would be extremely confusing for the users.

       

      So, how do I hide the Index tab?

       

      My secondary dilemma is that I want Auto-syncronize TOC enabled in both chm files.  What I just noticed is that as soon as I swap topics, the Home and Index buttons point to the relative paths in the OTHER chm file and when pressed, the current chm can't find them.  Is there a format of path I can use that is sort of relative but sort of fixed at the same time so it won't get confused?  The chm files can be moved around to different directories but they will always be together as sibling files.  I feel like I've opened a bottomless can of worms.  (I know the perfect solution to this would have been one chm with conditional tags per language but we had to convert from existing .hpj projects and had no time to merge everything manually for that solution.)

       

      Any suggestions?

        • 1. Re: Index Tab Be Gone! (How?)
          Irosado

          Under Single Source Layouts (View | Pods | Single Source Layouts) right click on WebHelp(Primary Layout) and select properties.  select next and it should take you to a screen to modify the toolbar buttons.  That's how I made our Index tab go away.

          • 2. Re: Index Tab Be Gone! (How?)
            MaritimeGirl Level 1

            Isn't that only for WebHelp?  I have chm files which are HTMLHelp.

            • 3. Re: Index Tab Be Gone! (How?)
              RoboColum(n) Level 5

              Perhaps I can add a bit to this conversation as how you control an Index does indeed differ between outputs. With CHM file output there is an option in the Window definition that controls the tabs that are displayed. However the available window properties are controlled by what the default single source layout was when the window was created. For example the default SSL was WebHelp when the window was created you won't be able to set the tabs to appear or not to appear in CHM output.

               

              With windows created with a default SSL of Microsoft HTML Help you get a tab that controls both the TOC and Index appearing. Not one or the other. However if there are no index keyword definitions, you can still have this option selected but no index tab is displayed. So it sounds like as you have your keywords in a seperate topic that is the way to go.

               

              As a side comment, you may want to think again about this approach. RoboHelp 8 now includes index keywords in the search algorihum it uses to find topics when a user searches.

               


              Read the RoboColum(n) for a tips,  tricks and musings on the Technical Communication Suite products.

              1 person found this helpful
              • 4. Re: Index Tab Be Gone! (How?)
                MaritimeGirl Level 1

                Aha.  I deleted the .hhk and then noticed that RH automatically created a brand new one.  At least it's smart enough to realize that if the file is empty, don't show the Index.  I recompiled and it disappeared - perfect, thank you   (The default search still seems to work fine - we have Advanced Search turned off.)

                 

                Now, that leaves my other issue with the Custom Buttons and the Home button.  I'm shooting in the dark at the moment looking for a url format that I can use to be relative yet include the destination chm name along with the topic.

                 

                Setup:

                CHM English - Home points to HomeEnglish.htm, Custom Button 1 points to IndexEnglish.htm, TopicEnglish has hyperlink to TopicFrench.

                CHM French - Home points to HomeFrench.htm, Custom Button 1 points to IndexFrench.htm, TopicFrench has hyperlink to TopicEnglish.

                 

                In CHM English, I navigate to TopicEnglish, click the hyperlink which opens TopicFrench within the CHM English content frame, then press either Home or Custom Button 1.  It tries to go to HomeFrench.htm or TopicFrench.htm but in the CHM English.  How do I tell it which chm to look at?

                 

                (I've tried with Auto-synchronize TOC on and off - no difference in behaviour.)

                • 5. Re: Index Tab Be Gone! (How?)
                  RoboColum(n) Level 5

                  As you have found, you need a .HHK file. The easiest way to delete an index is to open the index pod, select the first keyword and place a heavy book on the delete key :-) As far as the link is concerned, have you tried specifying both the CHM and topic name (e.g. english.chm::/englishtopic.htm)

                   


                  Read the RoboColum(n) for a tips,  tricks and musings on the Technical Communication Suite products.

                  • 6. Re: Index Tab Be Gone! (How?)
                    MaritimeGirl Level 1

                    Oh I see what it's doing.  When I do my language swap, it's opening the window from the other chm since I opened a topic from the other chm.  I happened to notice this because of the positioning - I had moved the chm away from top/left and when I switched language, it returned to top/left.  My window in each chm is configured the same except for the Home and Custom Button and the Window Caption due to language.

                     

                    So, I guess my question is this - how do I open a topic from another chm in my current chm content frame without triggering it open the window from the other chm?  Essentially, I want to treat the remote topic as a remote url and pretend it's not from another chm.

                    • 7. Re: Index Tab Be Gone! (How?)
                      RoboColum(n) Level 5

                      I don't believe you can using RH as you'll adopt the other CHMs characteristics. Maybe someone else can confirm this? Maybe you could write some Javascript to do this for you but you'd have to do this yourself or look for some scriot code you can modify.

                       


                      Read the RoboColum(n) for a tips,  tricks and musings on the Technical Communication Suite products.

                      • 8. Re: Index Tab Be Gone! (How?)
                        MaritimeGirl Level 1

                        I'm currently using javascript do accomplish the language swap via Master Page hyperlink which dynamically determines the destination chm file and topic.

                         

                        My only theory was to possibly use a Shortcut control in the Master Page header and dynamically change the param value for the target but the problem there is it opens a second HTML Help viewer for the other chm file, thereby defeating the purpose of this hyperlink.

                        • 9. Re: Index Tab Be Gone! (How?)
                          MaritimeGirl Level 1

                          Unbelievable.  I found the solution via a last ditch attempt.  I created a brand new window in the misbehaving chm and copied over all of my settings, leaving the "bad window" there, chose the new window as the default, recompiled.  It all works.  So, it seems that you can't do what I'm doing if the window is named the same in both chm files or else the viewer has a temper tantrum and does very bad things to the buttons and the tabs (see previous post.)

                           

                          So, renaming my window in either chm file would have done the trick.  Hours and hours of painfully going through every setting with a fine-toothed comb to make sure everything was the same, recompiling I swear 101 times to find this is all I needed to do to fix the problem.