2 Replies Latest reply on Oct 15, 2009 12:45 AM by jezzthisisfull

    Layers of imported .psd files are cropped?

    jezzthisisfull Level 1

      Hi, when importing .psd files the images on layers are cropped...?

       

      In Photoshop an image on a layer is moved across the visible portion of the document as if it is animated, through the use of comp layers (each new comp layer the image is move a little bit).  However after importing the .psd into After Effects only a portion of the image is visible...it is impossible to recreate the animation roughed out with Photoshop comps because some of the image on the layer being moved is cropped. 

       

      I hope that makes sense...how can .psd files be imported into After Effects without cropping?  Thanks

        • 1. Re: Layers of imported .psd files are cropped?
          Mylenium Most Valuable Participant

          What options did you use when importing them? They should in any case come in at full res when imported as single footage layers and when choosing Composition - Cropped Layers (that is, cropped per layer to the layer content). They only should get cropped with normal Composition mode, as that uses the document dimensions. There are a few issues with PSD handling in older versions of AE, but you didn't say which one you are using. More info would therefore help.

           

          Mylenium

          1 person found this helpful
          • 2. Re: Layers of imported .psd files are cropped?
            jezzthisisfull Level 1

            Thanks so much for such a prompt reply...the single .psd file with many layers is imported using:

             

            Import Kind: Composition

            Layer Options: Editable Layer Styles; Life Photoshop 3D (although there are no 3D layers in the .psd...so I'm unsure if this default is needed?)

             

            Oh!!  Never mind...I just tried Import Kind: Composition -- Cropped Layers and the layers were not cropped...kind of counter-intuitive since I would have thought "Cropped Layers" would crop the layers rather than the other way around. 

             

            Thanks for your help...if you just reply to this post I'll mark your reply as the answer, thanks for suggesting the direction to look for a solution, cheers!