4 Replies Latest reply on Oct 22, 2009 4:59 PM by jdesko

    Flash Builder Beta 2 output folder issues

    jdesko Level 2

      I have a project that was created in FB Beta were everything was working fine; just updated to FB Beta 2 (uninstalled FB Beta).  With the existing project from FB Beta, I had to completely reset it up in FB Beta 2 (Data/Services, gateway.php, amf-config.ini, etc.).  The problem is in the Project's properties output folder FB keeps setting it to -> bin; in setting up the project I specified bin-debug, in FB Beta I was using bin-debug, if I click on restore defaults it sets bin-debug, but when I go back to properties it's back to bin.  I've never used bin in the past.  I've also had where FB creates a bin folder to put the output in (this is inconsistent) and when it does my .php files that are in the services folder are deleted/removed.  Pictures to describe are below.

       

      I select Restore Defaults / or manually type in bin-debug/ also this is how the project was created

      Picture 2.png

      I go back to the projects properties and get this

      Picture 1.png

        • 1. Re: Flash Builder Beta 2 output folder issues
          David_F57 Level 5

          Hi,

           

          when you change the folder back to bin-debug does the package explorer update to indicate the change has been made ?

           

          Also have you tried to manually name the output path  outside of Flashbuilder then edit the actionscriptproperties file to to new path. (i'm a PC person so i'm assuming the mac projects are structured in a similar way to the PC).

           

          David.

          • 2. Re: Flash Builder Beta 2 output folder issues
            jdesko Level 2

            Thanks for the reply David.

            when you change the folder back to bin-debug does the package explorer update to indicate the change has been made ?

             

            Every time that I go into the projects preference under the output folder it always shows bin, but it inconsistently removes bin-debug and creates a bin folder and removes bin-debug.  Every time that I'm in properties I always make sure that I save with bin-debug set, so package explorer does show bin-debug. 

             

            Also have you tried to manually name the output path  outside of Flashbuilder then edit the actionscriptproperties file to to new path.

             

            I've always used bin-debug so I didn't have to manually name;  actionscriptproperties does show bin-debug also. 

             

            I don't know if you wanted me to try a new folder to see what happens?  I haven't,  I'd rather figure out why bin is always set.

             

            Thanks for the help and the reply,

            John

            • 3. Re: Flash Builder Beta 2 output folder issues
              tlaneadobe Level 1

              Hi John. I can reproduce your problem exactly. I've filed this bug on it: http://bugs.adobe.com/jira/browse/FB-23564

               

              Thanks much for posting,

              Tom

              • 4. Re: Flash Builder Beta 2 output folder issues
                jdesko Level 2

                Hello Tom,

                 

                Did you just hear that big sigh of relief?  I'm glad it wasn't user error; I'm also happy that I'm religious about backups, even more so now with this bug.

                 

                Thanks much for the reply and filing a bug report.

                 

                John