1 Reply Latest reply on Oct 16, 2009 3:05 AM by Matt Le Fevre

    Images taking a long time to load

    Phoenix_Guru Level 1

      Hi,

       

      I have a custom button component as following:

       

      <mx:HBox>

            <mx:Button  id="btnBack"

                              label="Back"

       

       

                              styleName="

      NavigationButton"

                              icon="@Embed(source='/com/guruji/project/assets/Left.gif')"

       

       

       

       

       

                              click="dispatchEvent(

      new Custom_ButtonEvent('buttonClicked',"back"));"/>

       

       

       

       

       

       

       

           <mx:Button

       

      id="btnNext"

                          label="Next"

                          styleName="

      NavigationButton"

                          icon="

      @Embed(source='/com/guruji/project/assets/Right.gif')"

                          click="dispatchEvent(

      new Custom_ButtonEvent('buttonClicked',"

      new Custom_ButtonEvent('buttonClicked',"

       

      next"));"/>

      </mx:HBox>

       

       

       

      I use this button (the whole HBox) component on every screen of my application. As per the performance testing results, these images are taking a long time to load. How can I optimize the loading of these images? Is there a way that these images get loaded only once in the whole application?

       

      Thanks,

      Saurabh