0 Replies Latest reply on Oct 16, 2009 10:38 AM by kloysen

    blazeds help

    kloysen Level 1

      So I have a problem that has been bothering me for a few weeks now. My backstory is a Flex front end that connects to a java backend located on the same server.  It is running on a tomcat server.  When you are inside the firewall everything runs fine in firefox but crashes in IE.  When outside the firewall you can reach the swf but get back a very long server 500 error.  This is my remote object:

      <mx:RemoteObject id="ldapConnect" destination="ldapService" showBusyCursor="true"
              endpoint="https://servername/blazeds/messagebroker/amf">
              <mx:method name="getAllUsersXML" result="getAllUsers(event)" />

              <mx:method name="clearCache"/>
          </mx:RemoteObject>

       

      this is part of my services-config.xml file

       

      <!-- Servlet Based endpoints -->
              <channel-definition id="my-amf" class="mx.messaging.channels.AMFChannel">
                  <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/amf" class="flex.messaging.endpoints.AMFEndpoint"/>
                  <properties>
                      <polling-enabled>false</polling-enabled>
                  </properties>
              </channel-definition>

       

              <channel-definition id="my-polling-amf" class="mx.messaging.channels.AMFChannel">
                  <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/amfpolling" class="flex.messaging.endpoints.AMFEndpoint"/>
                  <properties>
                      <polling-enabled>true</polling-enabled>
                      <polling-interval-seconds>8</polling-interval-seconds>
                  </properties>
              </channel-definition>

       

              <channel-definition id="my-http" class="mx.messaging.channels.HTTPChannel">
                  <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/http" class="flex.messaging.endpoints.HTTPEndpoint"/>
              </channel-definition>

       

              <!-- Secure Servlet-based endpoints -->
              <channel-definition id="my-secure-amf" class="mx.messaging.channels.SecureAMFChannel">
                  <endpoint url="https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure" class="flex.messaging.endpoints.AMFEndpoint"/>
                  <properties>
                      <!--HTTPS requests on some browsers do not work when pragma "no-cache" are set-->
                      <add-no-cache-headers>false</add-no-cache-headers>
                  </properties>
              </channel-definition>

       

              <channel-definition id="my-secure-http" class="mx.messaging.channels.SecureHTTPChannel">
                  <endpoint url="https://{server.name}:{server.port}/{context.root}/messagebroker/httpsecure" class="flex.messaging.endpoints.SecureHTTPEndpoint"/>
                  <properties>
                      <!--HTTPS requests on some browsers do not work when pragma "no-cache" are set-->
                      <add-no-cache-headers>false</add-no-cache-headers>
                  </properties>
              </channel-definition>