15 Replies Latest reply on Nov 17, 2009 8:32 AM by WebDevByGeorge

    Trouble installing Beta 2

    Gegad

      So I had the error message of license expired with the FlashBuilder Beta a couple days ago and once I figured out I needed to get the new beta, I uninstalled the Beta 1, restarted my machine, downloaded Beta 2, installed it and then went to run Eclipse.

       

      Once installed, the Flashbuilder 4 Beta 2 plug-in does not show up as a persective that I can open inside of eclipse (Ganymede 3.4.2) - when I installed Beta 2 I pointed it to my eclipse folder under ./Applications/eclipse/

       

      However, if I navigate to the ./Applications/Adobe Flash Builder Plug-in Beta 2/ folder, and run the "Run Adobe Flash Builder Plugin Beta 2" alias, it opens up a seemingly different copy of eclipse wherein I can use the Flash Builder plug-in... but none of my other plug-ins that should be installed (notably subclipse for SVN).

       

      Is this how it's supposed to work, or am I messing up the installation/upgrade process somehow?

        • 1. Re: Trouble installing Beta 2
          C. Agruss (Adobe) Level 3

          Hi,

           

          Here's a workaround for this issue:

           

          1) If you’re using your own copy of Eclipse, enable Classic Update in Eclipse Preferences > General > Capabilities > Classic Update.

          2) If your eclipse distro doesn't provide the Classic Update option in preferences, you can enable it as follows:

           

          a) In the default workspace (/yourUserName/Documents/Adobe Flash Builder Plug-in Beta 2/), locate the following file: /.metadata/.plugins/org.eclipse.core.runtime/.settings/org.eclipse.ui.workbench.prefs

          b) At the end of that file, add the following line: UIActivities.org.eclipse.equinox.p2.ui.sdk.classicUpdate=true

           

          3) Add FB4 as a product extension, using these steps:

          Invoke Help > Software Updates... > Manage Configuration

          Add an extension folder, pointed to the FB4 Plug-in subfolder named eclipse.

           

           

          Let us know if that works for your configuration,

           

          -Chris

          • 2. Re: Trouble installing Beta 2
            substance

            Having the same problem even after this suggestion.

             

            *I should probably note that I also have the Subclipe plugin on my default version of Eclipse(3.5.1)

            • 3. Re: Trouble installing Beta 2
              C. Agruss (Adobe) Level 3

              Subversion shouldn't interfere, so probably not a conflict there.

               

              Have you already tried this appoach:

              - switch to a fresh new eclipse workspace, then

              - look under Window > Open Perspective > Other... for the Flash perspectives

               

              -Chris

              • 5. Re: Trouble installing Beta 2
                C. Agruss (Adobe) Level 3

                Hi,

                 

                In your second to last post you included a screenshot of your Product Configuration dialog, with the Flash Builder portion of the tree expanded.

                 

                If you expand the top part of the tree (d:\program files\eclipse), along with all of its sub-features, are there any of those showing status errors? I ask because we've seen that after there's an error in any other feature/installation, nothing else can be added to eclipse successfully until the original error has been cleared. This might not be the case for you, but just want to rule that out.

                 

                If you expand the whole tree, and send a screenshot of that, we can make sure of that, and can also look for other possible incompatibilities.

                 

                Another way to check this is to try installing some other small feature from eclipse's own Galileo discovery site, to see if you can add anything else successfully at this point.

                 

                Thanks,

                 

                -Chris

                • 6. Re: Trouble installing Beta 2
                  substance Level 1

                  No errors from what I can tell and I was able to install a feature seemingly successfully.

                  • 7. Re: Trouble installing Beta 2
                    C. Agruss (Adobe) Level 3

                    You've pretty well stumped me now.

                     

                    Maybe try disabling subclipse temporarily, as an experiment, to rule that out. Maybe you already did that though, because I don't see it in your latest config list.

                     

                    If you run the bundled copy of eclipse (3.4.2) that was included with FB4 Plug-in Beta 2, do the perspectives show up normally there?

                     

                    -Chris

                    • 8. Re: Trouble installing Beta 2
                      substance Level 1

                      I did not disable subclipse(but you're right, it's not on the list for some reason so i cant disable it if I wanted to).

                       

                      Everything works fine with the bundled eclipse.

                      • 9. Re: Trouble installing Beta 2
                        Gegad Level 1

                        I go through all the steps and I've gone through multiple installs and uninstalls of the plugin and always to the same effect. I've tried using fresh workspaces as well, no luck.

                         

                        If I launch my eclipse, the only Flashbuilder related perspective available is "Flash Profile", as attached below. There must be some sort of conflict with an existing configuration file that doesn't get deleted when I uninstall the Flashbuilder plugin.

                         

                        If I run eclipse directly from the flashbuilder 2 beta plugin folder, it works, but then none of my other installed perspectives (such as Subclipse) work. Any more thoughts would be appreciated.

                        • 10. Re: Trouble installing Beta 2
                          C. Agruss (Adobe) Level 3

                          Hi Gegad,

                           

                          Uninstalling/reinstalling isn't likely to change anything, but did you already try the steps listed above for configuring FB4 Plug-in as a product extension?

                           

                          Often this will work, but let us know one way or the other.

                           

                          -Chris

                          • 11. Re: Trouble installing Beta 2
                            Gegad Level 1

                            Sorry if it wasn't made clear but yes, indeed I have gone through all the

                            processes listed above and none seem to have any impact on the perspectives

                            that can be loaded into Eclipse.

                            • 12. Re: Trouble installing Beta 2
                              C. Agruss (Adobe) Level 3

                              Thanks Gegad, really appreciate the info.

                               

                              Exactly which version of subclipse to you have installed? I want to try that here to see if I can repro the conflict.

                               

                              Also, if you have any logs handy from your workspace .metadata folder, or from your configuration folder, please send them along and I'll scan them for clues.

                               

                              -Chris

                              • 13. Re: Trouble installing Beta 2
                                WebDevByGeorge

                                I'm having the same difficulty as Gegad is having in my installation of Flash Builder 4 Beta Plugin 2. 

                                 

                                I do see mention of the Flash Builder in my .metadata log as follows:

                                 

                                !SUBENTRY 1 org.eclipse.ui 4 0 2009-11-16 16:15:42.625

                                !MESSAGE No editor descriptor for id com.adobe.flexbuilder.ui.StartPage

                                 

                                !ENTRY org.eclipse.ui 4 0 2009-11-16 16:15:42.671

                                !MESSAGE Unable to create editor ID com.adobe.flexbuilder.ui.StartPage: No editor descriptor for id com.adobe.flexbuilder.ui.StartPage

                                 

                                !ENTRY org.eclipse.ui 4 4 2009-11-17 09:03:11.765

                                !MESSAGE Category com.adobe.flexbuilder.mxml.editor.views not found for view com.adobe.flexbuilder.monitors.network.view.NetworkMonitorView.  This view added to 'Other' category.

                                 

                                Do you want the other errors that are occurring in the log as well?

                                 

                                George

                                • 14. Re: Trouble installing Beta 2
                                  C. Agruss (Adobe) Level 3

                                  Thanks George - we were able to repro some of these errors internally, and are working on the fixes.

                                   

                                  If you have a longer list of errors available, that would help, to make sure we don't overlook anything.

                                   

                                  Thanks,

                                   

                                  -Chris

                                  • 15. Re: Trouble installing Beta 2
                                    WebDevByGeorge Level 1

                                    I've attached the .metadata log.  There seem to be some errors with the ColdFusion Plugin as well but I don't believe they would be causing this same type of problem.

                                     

                                    George