0 Replies Latest reply on Oct 21, 2009 5:27 PM by ilevina

    Having issue, when trying to use HTTP secure-channel instead of HTTP

    ilevina

      Our Flex application uses LCDS(we are using ColdFusion8 that has integrated LCDS) to proxy Web Service, it works fine if I am using HTTP non-secure channel.

       

      We changed proxy-config.xml to define destination that uses non-secure channel as follows:

       

      <?xml version="1.0" encoding="UTF-8"?>
      <service id="proxy-service"
          class="flex.messaging.services.HTTPProxyService"
          messageTypes="flex.messaging.messages.HTTPMessage,flex.messaging.messages.SOAPMessage">

       

          <properties>
              <connection-manager>
                  <max-total-connections>100</max-total-connections>
                  <default-max-connections-per-host>2</default-max-connections-per-host>
              </connection-manager>
              <allow-lax-ssl>true</allow-lax-ssl>
          </properties>

       

          <adapters>
              <adapter-definition id="http-proxy" class="flex.messaging.services.http.HTTPProxyAdapter" default="true"/>
              <adapter-definition id="soap-proxy" class="flex.messaging.services.http.SOAPProxyAdapter"/>
          </adapters>

       

          <default-channels>
              <channel ref="java-http"/>

          </default-channels>

       

       

         <destination id="SomeService">
             <properties>
                 <wsdl>http://eng.com:8080/webservices/SomeService.wsdl</wsdl>
                 <soap>http://eng.com:8080/webservices/</soap>
                 <remote-username>suser</remote-username>
                 <remote-password>password</remote-password>
             </properties>
             <adapter ref="soap-proxy"/>
         </destination>

      </service>

       

      To use secure HTTP channel, we canhged the following elements in proxy-config.xml

       

      <default-channels>
               <channel ref="java-secure-http"/>

      </default-channels>

      <destination id="SomeService">
              <properties>
                  <wsdl>https://eng.com/webservices/SomeService.wsdl</wsdl>
                  <soap>https://eng.com/webservices/</soap>
                  <remote-username>suser</remote-username>
                  <remote-password>password</remote-password>
              </properties>
              <adapter ref="soap-proxy"/>
          </destination>

       

      When I am trying to use proxy-config.xml with secure HTTP channel defintion, connection to the WebService failed with an error: "Can't load WSDL. Check WSDL url".  Any help or suggestions what we are doing wrong?

       

      Thanks in advance

       

      Irene