3 Replies Latest reply on Jul 3, 2010 7:09 PM by s0mus

    cfajaxproxy callback doesn't work! HELP!

    nonnybonny Level 1

      I have created an application which uses the CFAJAXPROXY tag extensively to call functions through Javascript. Everything works fine on my local machine (Vista, CF8,all browsers).

       

      When I upload the files to the server, the CallBackhandler function stops working. Using the CFDEBUG window I can see that the call to the CFC is actually made AND it returns the desired result... yet, it doesn't do anything with the result. It just does nothing!

       

      The Callbackhandler(s) refresh the page elements (such as CFDIVS and CFLAYOUTS) in order to show the updated data. It just doesn't work!

       

      There is no error but there are several warnings in the Error Console in FF that state stuff like:

       

      "Warning: reference to undefined property o.stopPropagation

      Source File: http://xxx.xxx.xxx.xxx/CFIDE/scripts/ajax/ext/ext-core.js

      Line: 17"

       

      I am guessing this has something to do with it but am not sure what and why.

       

      I am also guessing that there may be an issue with the paths/mappings of the site that may cause the callbackfunction to lose track or something like that since the structure of the site IS different locally than it is on the server... however, when I call the templates directly (not through the root of the site) it still doesn't work.

       

      I also tried to upload the entire CFIDE/scripts directory and try and point my <cfajaximport> tag to it, but that throws an error (which also doesn't make any sense):

       

       

       

                  Invalid usage of AJAX tag.          

                            Use cfajaximport tag to specify SCRIPTSRC or make sure all ajax controls are inside a single cfform tag that has SCRIPTSRC.           The error occurred inC:\Inetpub\wwwroot\xxxx\xxx\conferencemgr.cfm: line 52
                    

                  
      50 : <!--- i
      
      
      mport Ajax Tags --->
      51 : <!--- <cfajaximport  tags="cfform,cfinput-datefield,cfwindow,cfinput-autosuggest,cflayout-border, cflayout-tab, cfdiv"> --->
      52 : <cfajaximport scriptsrc="/js/cfide/scripts/">
      53 : 
      54 : 
      

       

       

      So, although I think it is related to the JS files in the CFIDE directory and that for some reason it can't find the script for the callbackhandler function in the page, it just does nothing.

       

       

      Maybe I am completely wrong and I don't want to steer anyone in the wrong direction so if you have any better ideas, please let me know.

       

      I can't find any information about this issue anywhere (perhaps I have stumbled upon something unique!?). And, just to reiterate... everything works fine on my local server!

       

       

      Thanks for any help!

        • 1. Re: cfajaxproxy callback doesn't work! HELP!
          speedpedal Level 1

          My hunch is that the CFIDE folder is moved from your webserver to a different location. Check the path of your  

          1. Open CFadmin

          2. Click Settings and look for

          3. Check the path and point it to correct location of CFIDE.

           

          The above is a more easier way, since you won't have to specify a "scriptsrc" in cfajaxproxy tag.

           

          Looking at your <cfajaximport> tag, mage sure the js/cfide/scripts is relative to the webroot, if you want to do it that way.

           

          HTH

           

          Melvin T.

           

          • 2. Re: cfajaxproxy callback doesn't work! HELP!
            nonnybonny Level 1

            Hi Melvin,

             

            Thanks for your response.

             

            I did start to think that it has something to do with that. I tried every which way to point to the correct CFIDE directory but to no avail.

             

            I copied the entire directory into the root folder of the site, and tried to point the CFAJAXIMPORT SCRIPTSRC to it, but it still doesn't work.

             

            However, because the site's root directory is different from the web root, it may have something to do with it. I just can't figure out what.

             

            The server is not mine, BTW, and I don't really have access to CFAdmin. Because all the imported tags are working I believe the directory is pointing in the right direction.

             

            I am at a loss.

             

            I have a working copy here: http://76.12.219.84/erdi/conferencemgr.cfm?action=registration&conference_id=23&user=5555

            • 3. Re: cfajaxproxy callback doesn't work! HELP!
              s0mus

              This can happen when the scripts were not copied correctly.  If a file becomes corrupted or an ascii file gets uploaded in binary or the file get truncated.. all of these could throw that error.  Seeing as there are roughly 2,300 files in the scripts folder in CF8, it's not unusual for something to get munched.  Try replacing the files and let us know if that solved it.