10 Replies Latest reply on Nov 27, 2009 5:35 PM by the_wine_snob

    Choppy Playback with MTS files

    dmoore210

      I am recording video with a Canon HG10 video camera which exports with MTS files. Although when I import them to Adobe Premiere Pro CS4, and try to edit the video is extremely chopping. Uneditable. I'm not sure if it's my hardware specs or something I can improve with the software. Any help?

       

      Gateway

      Core Duo @ 2.0 ghz

      4gb Ram

      Vista 64bit

        • 1. Re: Choppy Playback with MTS files
          Sloz

          I had the same problem with mts files from my Sony XR520. Look in the source window and find the drop down just above the top right corner and click. Find the quality setting and click "highest quality"  Do the same thing in the program window.  I did this and now the mts clips play perfectly in the source and program windows. I hope it works for you too.

           

          Cheers,

          Phil

          • 2. Re: Choppy Playback with MTS files
            dmoore210 Level 1

            thanks, the source window plays pretty well now. It's actually playing around 20fps. But the program window is still the almost unplayable.

            • 3. Re: Choppy Playback with MTS files
              Harm Millaard Level 7

              You may benefit from some more horsepower. Core 2 Duo @ 2.0 GHz is underpowered.

              • 4. Re: Choppy Playback with MTS files
                ChrissaSwenson Level 1

                Do you see a red line above the timeline?  If so, your source material does not match the Sequence Settings that you have selected, and playback will suffer.

                 

                If you have selected the correct preset, or have set the correct settings for a Sequence manually, then there is one more thing you can do which will improve playback.

                 

                Most of my material from my Canon HD camcorder is 1080p stuff, taken in "30p" framerate.  I select a 1080p preset that is for 30p framerate, and the source material shows no red or yellow line above the timeline.  BUT, it is still a bit choppy-looking when played.  I have found that this can be improved by right-clicking on the source clips in the Project pane and "Interpreting Footage" as Progressive (no field order).  You can do that either before laying clips to sequence or after -- it affects them in the timeline after placement, too.

                 

                (This interpretation bit seems to be helpful because many Canon cams actually record their 24p and 30p material in a 60i foundation and manipulate the data to provide the progressive output.  You will see evidence of this if you put such footage (even if it's called 30p) into a 60i timeline, Premiere likes it just fine (sort of) and gives no red or yellow need-for-rendering line.  If you capture in 30p all the time, you don't need to worry about any of this if you just Interpret Footage as above and treat is as 30p.)

                 

                Harm's advice is true in general for AVCHD material, but it has to be qualified to be of value, else it, as here, does not address your system's potential thoughtfully.  If advice such as given is not qualified carefully, you can waste a lot of money on a hotter machine when you in particular may not need one.

                 

                I have edited many relatively short high-bitrate AVCHD projects with a 2.66 GHz Core 2 Duo -- it all depends upon your needs.  If you do not care about perfectly smooth playback video in timelines and your editing functions work fine and you either are not adding effects to your Sequence or are not compelled to render effects and transitions in your material if you do use them, your system might be just fine for you.  You may be fine with going to bed while your project is encoded with the Media Encoder (or waiting into the next day!).  I was okay with this at times -- I just had to get over the idea that rendering was needed all the time.  I didn't need faithful playback of effect-laden timelines most of the time, because I knew their content and could see the effects well enough without rendering.

                 

                You'll find your limit, but it is hopefully good to know you can work with your system under reasonable conditions if you understand what's going on and accept the limitations with intelligent compromises.  Even if you get a stronger system, you will benefit from such considerations anyway.

                • 5. Re: Choppy Playback with MTS files
                  Joker B Level 1

                  Harm's comment is correct -- you don't really have enough CPU horsepower to live-decode files from the HG10

                   

                  Suggestions: copy your clips to another format (e.g., AVI)  using Adobe Media Encoder, Cineform Neo Scene, or (possibly) Panasonic's DVCPRO  transcoder. All of these formats should be much easier to edit on your system, and at the correct playback speed.

                  1 person found this helpful
                  • 6. Re: Choppy Playback with MTS files
                    dmoore210 Level 1

                    Thanks! I was able to get it playing smoothly now. I never noticed the red line above the file in the timeline. Having the correct presets was the key. And I don't need perfect playback while editing and don't mind leaving it render overnight. Thanks for the help.

                    • 7. Re: Choppy Playback with MTS files
                      KaiserBoy Level 1

                      Looks like the "more CPU" advice was a bit clumsy, and it brings up a good point.  Chrissa's post was about as relevant and detailed as it gets, addressing the poster's needs with her own specific experiences, and it nailed it for the poster.  Relevant via experience -- that's a good benchmark for response quality!

                       

                      As well, I see a bit of inconsistency in the advice tossed out for AVCHD editing.  Sometimes it is the CPU that is not good enough, other times is it that the poster doesn't have enough fast hard drives, other times it is that they don't have enough RAM.  I don't know which is more critical, actually, but seeing them mentioned inconsistently makes me wonder about the advice.

                       

                      Nice save, Chrissa!  You stuck to what you know and it helped.

                      • 8. Re: Choppy Playback with MTS files
                        Jeff Bellune Adobe Community Professional

                        Sometimes it is the CPU that is not good enough, other times is it that the poster doesn't have enough fast hard drives, other times it is that they don't have enough RAM.  I don't know which is more critical, actually, but seeing them mentioned inconsistently makes me wonder about the advice

                        The advice given is only as good as the info given by the OP.  It is often assumed that if info is omitted, such as sequence settings and footage properties, that the OP knows what they're doing and has set the sequence and interpreted the footage correctly.  If those basics aren't taken care of, then no amount of CPU power or RAM or anything else will matter.

                         

                        Chrissa's insight was invaluable this time, but had the OP's response been, "I've already used the correct preset, and the footage is interpreted correctly", then chasing down hardware capability and system settings would have been necessary to try to solve the problem.

                         

                        @Chrissa,

                         

                        Well done!

                         

                        -Jeff

                        • 9. Re: Choppy Playback with MTS files
                          mga56grg1

                          I've had this choppy MTS problem for a year, until reading this. i had been using other presents, but now everything works wonderfully (and w/o jitter) in 60i.

                          • 10. Re: Choppy Playback with MTS files
                            the_wine_snob Level 9

                            That is good news, and glad that the forum was able to help you.

                             

                            Hunt