4 Replies Latest reply on Oct 27, 2009 10:31 AM by Solon Aquila

    TOC doesn't show in View Primary Layout

    Solon Aquila Level 1

      OK, this has got to be some minor little thing I'm not doing.

       

      I created a project by importing a PDF and creating topics based on a given style.

       

      In the Project Manager pod (?), under Project Files, I have 6 files. Each of the 6 files appears to be one of my topics. Good so far.

       

      A TOC wasn't created, so I right-clicked on each of the 6 files and selected New > Table of Contents.

       

      Now, still in Project Management, the Table of Contents folder has my entries, but when I use the View Primary Layout button, I get topics with no TOC (nothing in the navigation pane when Contents is selected). OK, that's not quite right, I get the FIRST topic in the content pane and a complete blank in the navigation pane.

       

      My computer does show a warning that Microsoft is protecting me from the evil Self-Inflicted virus by not allowing content to run unless I specifically authorize it, but I still have no contents when I allow the content.

       

      Is there some minor thing I'm not doing? (I'm taking it that the View Primary Layout is supposed to show what the end-result will be)

       

      Thanks,

       

      Solon

        • 1. Re: TOC doesn't show in View Primary Layout
          Peter Grainge Adobe Community Professional (Moderator)

          Only if you have generated it. You don't say you have done that.

           


          See www.grainge.org for RoboHelp and Authoring tips

          • 2. Re: TOC doesn't show in View Primary Layout
            Solon Aquila Level 1

            Well, I click a button that says "View Primary Layout" when I mouse over it. And when I do, it says "This only works if you've generated it, do you want to?" and I click yes and POOF, up comes IE with my files in it and nothing in the navigation pain.

             

            I don't see anything separate that says anything about generating a Table of Contents. I can't even find a Table of Contents pod (referred to in Help) in the View > Pods list.

             

            I have a Table of Contents folder in the Project Manager, but I don't think that qualifies as a pod.

             

            Solon

            • 3. Re: TOC doesn't show in View Primary Layout
              Peter Grainge Adobe Community Professional (Moderator)

              In Project Manager you should see Table of Contents listed. From what you say, instead of setting up the default TOC, you elected to create a new one. That will be confirmed by you seeing two entries under Table of Contents.

               

              Then probably what happened is instead of setting the wizard to use the new TOC, you left it with the default so you generated using the default instead of the TOC you had created.

               

              Double click the Primary Layout and change the TOC used in the first page to your new one and it should be OK.

               

              If you double click a TOC in Project Manager, you should see it open in a pod.

               


              See www.grainge.org for RoboHelp and Authoring tips

              • 4. Re: TOC doesn't show in View Primary Layout
                Solon Aquila Level 1

                Peter,

                I didn't see a table of contents on my first try, so, yes, I created entries and used those, though they didn't appear when I generated the primary layout.

                 

                So I started over with a new, blank project and figured out that if I click on an entry in the Table of Contents folder in the Project Manager, it opens the TOC pod. It looks like we're good there, except that it generated the TOC in reverse order (they're numeric entries, 4.5 is the highest one and 4.1 is on the bottom).

                 

                 

                Thanks,

                 

                Solon