1 Reply Latest reply on Oct 29, 2009 7:15 AM by paraglidersd

    PlotChart -  error #1009

    paraglidersd

      Hi All,

       

      I am getting an error #1009 on a flex plot chart that I have implemented.  The error seems to occur during (after?) the updateComplete event occurs (external data is loaded into the dataProvider for the chartSeries at runtime).  The very odd caveat to this is that if I remove the "selectionMode='multiple'" attribute setting from the plot chart, this error never occurs.  The flash error looks something like:

       

      TypeError: Error #1009 Cannot access a property or method of a null object
          at .....PlotSeries/findDataPoint[.......PlotSeries.as:900]
          at .....ChartBase/findDataPoints[........ChartBase.as:1974]
          at .....ChartBase/mouseMoveHandler[......ChartBase.as:4306]

       

      As I stated above, IF I remove the 'multiple' selectionMode the error never occurs.  I tried various other combinations such as: I tried completely disabling (not setting) my mouse events for the chart (mouseMove, mouseDown, mouseUp).  I also tried to not set the selectionMode UNTIL the updateComplete event was triggered on the Chart, but none of the things I have tried work...I still get that error UNLESS I completely remove the selectionMode='multiple'.  I need the multiple selection mode for my application, so not setting that is not an option for me.

       

      It seems the error is very generic.  I have no idea why its being triggered.  Is there a work around?  Can I register an error handler to throw this error away?  I did notice, in looking at PlotSeries.as in the findDataPoint function that there was a comment about a rendering problem.  Is this related?

       

      Any help would be appreciated.  If you need more information, I would be happy to provide it.

       

      thanks,
      Bill

        • 1. Re: PlotChart -  error #1009
          paraglidersd Level 1

          Interesting.  I ran an experiment and it 'seemed' to defer the problem (only tested a few times so far, though).  I used the setVisible() method on the plot chart....set to 'false' as I am reading data in to data provider and then 'true' after activcating the selectionMode in the updateComplete method.  Not sure yet if this is coincidence or a fluke (yet).  Just thought I would pass it along......any other ideas or suggestions are still very much appreciated.

           

          Bill