1 Reply Latest reply on Oct 29, 2009 2:31 AM by Mylenium

    Markers not exporting with FLV in CS3?

    TaoHunter Level 1

      I'm working on a flash project with various FLV files which I made with After Effects.

      In the flash file I use cuepoint data which comes from markers that I made with the "Convert selected properties to markers" script.

      Now from what I've been reading this shouldn't be a problem with CS3 but apparently it is because when I trace the cuepoint data in flash I get no response at all.

      I've tried the same thing with After Effects CS4 and then everything works perfectly.

      I've also tried this with both CS3 and 4 on Mac and there I had the same results. Not working in CS3 and working fine in 4.

       

      The script I use in Flash to trace the data is:

       

      var nc:NetConnection = new NetConnection();
      nc.connect(null);
      var ns:NetStream = new NetStream(nc);

       

      ns.onCuePoint = function(infoObject:Object)
      {
          trace("onCuePoint:");
          for (var propName:String in infoObject) {
              if (propName != "parameters")
              {
                  trace(propName + " = " + infoObject[propName]);
              }
              else
              {
                  trace("parameters =");
                  if (infoObject.parameters != undefined) {
                      for (var paramName:String in infoObject.parameters)
                      {
                          trace("   " + paramName + ": " + infoObject.parameters[paramName]);
                      }
                  }
                  else
                  {
                      trace("undefined");
                  }
              }       
          }
          trace("---------");   
      }

       

       

      I wasn't sure wether to post this question here or in the Flash forum but since the problem seems to be with After effects I posted it here.

      If anyone could shed some light on this it would be very much appreciated

       

      Grtz,

      TaoHunter

        • 1. Re: Markers not exporting with FLV in CS3?
          Mylenium Most Valuable Participant

          Yeah, it's possible. This has been twitchy in a number of iterations now, owing to the overall strangeness that is AE's marker system. The only other thing of note is the difference of the render queue vs. the export menu, but that may not be of relevance at all. Still, since you have CS4, it should not be too much of a problem, just an inconvenience. You may need to advise your co-workers to use the right version of the program and external suppliers to send you the project along with a version of the clips in a different format, just not pre-encoded FLVs. also do not forget, that using the XFL format to export such data to an XML file that Flash can read might also be a workaround. It's also CS4-only, though, so it's kind of a circular argument.

           

          Mylenium