16 Replies Latest reply on Apr 11, 2011 7:20 AM by pguerett

    Error "no credential found with alias"

    Vec123 Level 1

      Hi all,


          I'm running through an installation of LiveCycle ES with reader extensions.  Everything looks on the up and up, but I'm getting "No credential found with alias" in my logs.  I have the credential from Adobe installed in the livecycle config console with a random alias.  The question is where do I use this alias in my configuration?  I'm using WAS 6.1.

          I've searched the forums for this error and there was mention of it because there are some user permissions issues, but I'm running WAS under my account which is an admin user.

          Any help would be appreciated.



        • 1. Re: Error "no credential found with alias"
          pguerett Level 6

          When you installed the cert into LC you had to give an alias name to it. If you do not know what it is you can access it through the adminui application. IN many services when RE is being used or asked  for you need to enter the alias of the cert that you want to use. Which service are you using? I woudl make sure that RE is working prperly 1st. There is a web application that ships with it. Go to this URL and see if the screens come up:




          There is a Reader Extensions application user role so the only user who can use this (until you give that right) is admninistrator.



          1 person found this helpful
          • 2. Re: Error "no credential found with alias"
            Vec123 Level 1

            Very helpful.  I do know the cert alias name and am able to view all the info from the LC ES admin console.  I am able to log onto the RE console as well and I see all sorts of options there...and my cert listed on the left.  I'm guessing that these options are available to modify a single PDF file?  I'm not able to apply any of the options in this menu, but I doubt I have to anyway.  It's likely as you indicated


            "There is a Reader Extensions application user role so the only user who can use this (until you give that right) is admninistrator."


            Does this mean that I need to add the user that I'm running my WAS service from somewhere within the LC ES admin console so that it is allowed to use the certificate.  I've tried to find some white papers on this the RE, but I haven't found anything on it.

            • 3. Re: Error "no credential found with alias"
              pguerett Level 6

              No necccessarily ......1st things 1st ......ther eerror you were getting indicates that the alias name that you gave in the Service that you were using is not found ....that means that the RE cert is not even getting acessed correctly. Which service are you using and where did you put the cert (in which store).



              1 person found this helpful
              • 4. Re: Error "no credential found with alias"
                Vec123 Level 1

                I placed it in the Livecycle ES keystore...under adminui.  Settings->Trust Store Management -> Local Credentials.  Do I also have to configure WebSphere within the SSL configuration using the specified alias for that certificate?  We're using livecycle to render forms...xdp to allow users to save form data with regular adobe reader.

                • 5. Re: Error "no credential found with alias"
                  pguerett Level 6

                  Nope it is in the right place and you shoudl not have to do anything to websphere. Now how are you applying the Rights to the form? Through the UI that I showed you or through a process orchestration?



                  • 6. Re: Error "no credential found with alias"
                    Vec123 Level 1

                    Just to give a little overview.  I'm updating from LC 7.x to LC ES 8.  In addition to this LC resided on WAS 5.1.1 and is now on WAS 6.1.  The steps for reader extensions is significantly different (at least it seems so) in LC ES 8 & WAS 6.1.  To answer your question there is a custom coded portion that we have that must (I assume, based upon our discussion) interface with Reader Extensions somehow.

                    We have a custom app installed into Websphere via war/ear file.


                    Unfortunately I'm not the developer.  Using the information you passed along to me I took a regular form and was able to modify it through the ReaderExtensions UI console.  I'm thinking that there is a high probability with the custom code in how it interfaces with reader extensions.

                    • 7. Re: Error "no credential found with alias"
                      pguerett Level 6

                      You have validated that RE is setup correctly so we know that is not an issue. Previous to version 8 you had to bake the credential into the ear file. Part of that process involved defining an alias (I am going from memory so I might be a little off here). When the developers created that program they woudl have had to reference that alias that was created. In version 8 you add the credential after the fact and can see and deal with the alias without having to recreate the whole ear file. I am guessing that the alias that you gave it is not the same as th eone that is used in the code. If so you can solve this in two ways. Modify the code to use the alias that you gave the credential in Adminui or find out what alias was used in the past and delete the credential from the trust store and import it again giving it the alias that was used in the code.


                      That woudl explain the original error message that you recieved indicating that it could not find the alias (mentioned in the code). Does the error message include the alias name that it cannot find?



                      • 8. Re: Error "no credential found with alias"
                        Vec123 Level 1

                        I think you're right on the money with everything there.  That makes sense to me...I'll go back to my devs with this...the easiest change would be for me to get the alias from the code and just re-import the cert with that alias.


                        Second question.  I spoke too soon when I said that I was able to manually render a form.  I select a PDF to render..add a couple of options, click apply, then I get the process status page it runs through a couple of things down at the bottom very quick and then it stays at "Downloading".  I've let it sit there for quite a while.  The file hasn't been modified.

                        • 9. Re: Error "no credential found with alias"
                          pguerett Level 6

                          That sounds familiar - I think it had to do with the version of Flash Player. You probably have version 10 and that screen was built for 9. So you can either downgrade to 9 or there was a servicePack that was created to support version 10 of the flash player (SP2 I think).



                          • 10. Re: Error "no credential found with alias"
                            Vec123 Level 1

                            Right on the money...again.  Installed flash version 9 and I'm able to render the file manually.


                            Appreciate your help.  Thanks for all the tips.

                            I'll mark this as resolved as I suspect the other issues are custom code related to an incorrect reference to the RE certificate alias.

                            • 11. Re: Error "no credential found with alias"
                              g_weber Level 1

                              Just found this thread, I'm wrestling with a similar problem:

                              I have installed a credential, and can use the Web App as described

                              above to assign rights to PDF documents.

                              BUT I have a Java app that tries to do the same thing, and this fails

                              with a message "ALC-RES-001-002: Keine Berechtigung mit dem

                              Alias  [LCRE_Credential_20100630] gefunden" (german for "no

                              credential found with alias").


                              It got interesting, though, when I realized that my Java app worked just

                              fine when I let it connect as administrator to the LiveCycle Server, but

                              not as a "normal" user. That "normal" user has the ReaderExtensions

                              role, and can use the Web App without problems.


                              So if you get your remote app to work, I would appreciate any pointers

                              how you solved this.




                              • 12. Re: Error "no credential found with alias"
                                SForrest96 Level 4

                                Make sure that the context (i.e. user account) that the code is being executed as, has the correct permissions to "read" from the Trust Store (Credential Read).


                                Home > Settings > User Management > Role Management > Trust Administrator





                                • 13. Re: Error "no credential found with alias"
                                  g_weber Level 1

                                  Thanks a lot, that did it!



                                  • 14. Re: Error "no credential found with alias"


                                    I have the same problem but the solutions shown here did not help for me. I am unable to add RE to a pdf using the "administrator" credential. I have that in "local credentials" in the LC adminui. It is valid until 2012. I can use that credential to add RE to a pdf using the web interface for that, but from my java application it does not work.



                                    I get this Exception:

                                    java.lang.AssertionError: com.adobe.livecycle.readerextensions.client.CredentialException: ALC-RES-001-002: No credential found with alias [ADMINISTRATOR].




                                    In the java code I use this statement to add RE to the pdf:


                                    reClient.applyUsageRights(doc, "ADMINISTRATOR", null, reOptions);




                                    What am I missing here?




                                    • 15. Re: Error "no credential found with alias"
                                      ArneAtAdobe Level 1

                                      Problem solved. It is the solution that SForrest96 described.



                                      In the connection properties you give a username that your application uses to connect to the LC server. this user has to be in the role Trust Administrator, just like SForrest96 pointed out. Then you use the Alias of the certificate that you see in the ReaderExtensions web interface. If you have more than one, take the one that is valid. If this alias is LCRETRIAL3, then you use this line of code:


                                      Document rightsEnabledPDF = reClient.applyUsageRights(doc, "LCRETRIAL3", null, reOptions);



                                      BTW, you can see the exception in the server log of the LC server. When it says something like:


                                      Caused By: Insufficient Privileges for Credential Read -- (error code bin: 0, hex: 0x0)(CredentialServiceImpl.java100)


                                      then you know your user is not in the role Trust Administrator.





                                      • 16. Re: Error "no credential found with alias"
                                        pguerett Level 6

                                        When you imported the credential into the trust store you gave it an alias ...that is the name that shoudl be used to reference that credential. It shoudl also be imported into the Local Credentials store and when you do you need to idntify it as a Reader Extensions credential by clicking the appropriate checkbox.