0 Replies Latest reply on Oct 30, 2009 7:57 AM by diesel2404

    Please help.Tried all but still getting error: E_ADEPT_REQUEST_EXPIRED http://adeactivate.adobe.com/adept/Activate error

    diesel2404

      Hello everyone

       

      I recently downloaded digitial editions 1.7.1 and i really need it to download a book i recently purchased. But i keep gettng the same error message every time: E_ADEPT_REQUEST_EXPIRED http://adeactivate.adobe.com/adept/Activate

       

      I tried everything on the forum: check the time and date, try to change location and the web case server is down. I cant get help. Please I need to get the book. Can anyone help me? Thanks