2 Replies Latest reply on Oct 31, 2009 8:47 AM by newbieal

    button not displaying

    newbieal

      I have to add a button to a mxml file within the flex application (using FB3).  My code snippet is below.  Button does not display.  What could the reasons be? 

      How can I be certain that FB3 compiles the project (build automatically is checked)?  I don't always see that it builds the project and am concerned that something might not cause it to build properly and therefore can't see above button.

       

      <mx:TabNavigator id="aTabNav" width="{widgetWidth}" height="{widgetHeight}" creationPolicy="all" 
                             
      paddingLeft="10" paddingRight="10">
                             
      <mx:VBox id="vbox0" width="100%" height="100%" horizontalScrollPolicy="off" verticalScrollPolicy="off">
                                     
      <mx:Label text="{aLabel}" styleName="WidgetText" width="100%"/>
                             
      </mx:VBox>
                             
      <mx:VBox id="vbox1" width="100%" height="100%">
                             
      <mx:ApplicationControlBar id="controlBar" width="50%">
                                             
      <mx:Button id="aButton" label="Button1" color="#7FFFD4" />                     
                                     
      </mx:ApplicationControlBar>
                             
      <mx:Label text="{bLabel}" styleName="WidgetText" width="100%"/>
                                     
      <mx:Repeater id="aRepeater">
                                                     
      <widgets:Widgets something="{Widgets.currentItem}"/>
                                     
      </mx:Repeater>
                             
      </mx:VBox>
                     
      </mx:TabNavigator>