4 Replies Latest reply on Nov 2, 2009 6:23 AM by phunkya

    Dynamic Link Issue with Subclips into AE (CS4)

    Keephowlin

      I have Production Premium CS4 and am having a problem with Dynamic Link between Premiere Pro and After Effects.  I am access dynamic link via "Replace with After Effects Composition" on the Premiere Pro timeline.  When I first create the link, it starts up AE with the clip and I do all the groovy things I need in AE.  Premiere shows the changes and all is great... that is, until I save the work in both programs, close both programs and then open up the Premiere project again.  Premiere gives me the color bars placeholder and After Effects tells me it can't find the source file.  I've tried it every way I can think of (open AE first, open Premiere first, close AE first, close Premiere fist, etc.).  It fails every time in my system when I use Subclips as the source.  I just tried one with a regular clip (non-subclip), and it actually seems to work fine.  Is this a known issue with subclips or is there something I should try differently?

       

      Thanks,

       

      Rob

        • 1. Re: Dynamic Link Issue with Subclips into AE (CS4)
          Jim_Simon Level 8

          I've seen this before with subclips.  Use the original.

          • 2. Re: Dynamic Link Issue with Subclips into AE (CS4)
            Keephowlin Level 1

            Thanks for the response, Jim.  I was afraid of that.  Wow, what am I doing wrong workflow-wise...  I went through a library of long footage clips and created hundreds of subclips from them.  Now I can't use them through AE???

             

            The other thing this is that I've been playing with using regular clips through Dynamic Link and it is starting act up (in a different way).  Here's what I did...  I created a Premiere Project and imported a clip.  I put two copies of it on the timeline, one after the other.  I then linked the first one to an AE Comp, which opened AE and prompted me for a project file name.  I gave it one, did my effects and saved everything.  All worked well.  Closed both programs, restarted Premiere, loaded the project, and the effects were there and working.  I did an "Edit Orginal" on the first clip and it opened AE, and all was still good.  Then I linked the second clip to AE (while AE was opened), so it didn't prompt me for a new project.  It just created the new comp in the original project, I did my effects, and everything was still good.  Saved everything, closed both projects, re-opened Premiere and all the links were still in tact, everything still working.  Then I added the same clip to the timeline a third time, linked to AE (while AE was not open) and AE prompted for a new project name.  I gave it a new name, did my effects, saved everything, closed both programs.  Here's when the funky stuff happened.  When I re-opened Premiere, the first two clips show the lovely red "media not available" icon.  The last clip (that was in a different AE project) was fine.

             

            Am I doing things wrong still?  The help, tutorials and demos all look fine, and I can demo the feature fine, too.  I can't find anywhere where it really tellls you all the "gotchas" and workarounds.  How do people use this important feature when it seems so tempermental?  Also, once I get the "Media Not Available", what can I do to get it back?

            • 3. Re: Dynamic Link Issue with Subclips into AE (CS4)
              Jim_Simon Level 8

              If memory serves, keeping the third clip as a new comp in the same AE project will avoid this error.  I think I remember reading where multiple AE projects linked like this causes issues.

              • 4. Re: Dynamic Link Issue with Subclips into AE (CS4)
                phunkya Level 1

                Keephowlin,

                 

                Try this:

                 

                In AE, check you library to see if the clips have the "unknown file type" icon (rather than your normal video icon).

                 

                I am having this exact issue, and I've noticed that when I "create new AE comp" from Pr. the AE library shows that the media isn't linked correctly.  When I re-link (Ctrl + H, then select the orginal clip), the program seems to function better.

                 

                I'll be attempting this today, I'll let you know how it turns out.

                 

                Anthony