5 Replies Latest reply on Feb 6, 2013 10:23 AM by hwuAdobe

    Error entering preferences!! pls help!

    goxz

      Hi at all. Our company works with the Adobe Reader Version 9.1.3. We use Citrix XenApp 4.5 to distribute the Apllication to our Clients. It doesnt mather which rights we give to the users, every time we try to open the preferences, (Edit --> preferences) an error appears:

      "Failed to load an application resource (Internal Error)." The only option is, to click ok. The program closes after doing that.

       

      We tried following things on a test enviroment :

      Uninstall our Antivirus program.
      We gave the executing Users all possible rights.
      We installed Adobe Reader 9.2. Still same error.


      I hope there are any other people which already have experiance with Adobe Reader on Citrix XenApp.

       

      Regards

       

       

      I think I have an idea. But for that I need to know where else, besides in "C:/Program Files/Adobe" the Reader setup writes data.

      Please Help!

       

      Hmm still no replys =( no suggestions at all?

       

      Message was edited by: goxz

        • 1. Re: Error entering preferences!! pls help!
          RootFXCM

          We are having the same exact problem. Citrix XenApp 5.0 on Windows 2008 64-bit with Adobe Acrobat Standard 9.3.0.

           

          "Failed to load an application resource (Internal Error)" pops up when clicking Edit - Preferences. If we have an adobe PDF file open at that time - it crashes Adobe. Any help would be appreciated.

          • 2. Re: Error entering preferences!! pls help!
            RootFXCM Level 1

            So I did the following which seems to have stopped both crashes:
            In the following directory
            C:\Program

            Files (x86)\Adobe\Acrobat 9.0\Acrobat\plug_ins
            I renamed Accessibility.api and ReadOutLoud.api files to Accessibility.api.bak and ReadOutLoud.api.bak. The PDF files that used to crash adobe no longer crash it after renaming Accessibility.api and the Edit - Preferences menu started working after renaming the ReadOutLoud.api. So it appears that those 2 plugins were causing those issues.
            • 3. Re: Error entering preferences!! pls help!
              yellowpad95219

              I followed your advice and it worked like a charm.  Thank you.  I wish there was an easier fix than having to do that...

              • 4. Re: Error entering preferences!! pls help!
                trippap Level 1

                I encountered a similar problem in Acrobat Pro version 9.3.1, where I could not access Preferences. I had already moved Accessibility.api out of the plug_ins folder because of another issue, and when I also moved ReadOutLoud.api out of the plug_ins folder, I was able to access Preferences. That made me wonder whether Accessibility.api was involved with the Preferences problem, so I copied Accessibility.api back into the plug_ins folder and Preferences still worked. The culprit appears to be ReadOutLoud.api.

                • 5. Re: Error entering preferences!! pls help!
                  hwuAdobe Employee Moderator

                  Any chance I can get a crash dump with this please?
                  Has anyone tried this with a newer Acrobat/Reader version (ie. v11)?
                  I quickly tried this using XenApp 6 + Reader 11 and Acrobat 11 via Preferences and saw no crashes.
                  Any specific directions on how to reproduce this would be also valuable.

                  Please feel free to reach out to me at Adobe.
                  Thanks
                  David