7 Replies Latest reply: Nov 5, 2009 1:41 AM by Peter Grainge RSS

    Visual C++ Runtime "This application has requested the Runtime to terminate it in an unusual way"

    Colin David Foster

      RoboHelp HTML 6 and RoboHelp HTML 8 (Trial)


      A new technical author has joined the company and has been given an (domain based) login on the machine used by the previous technical author (now no longer with the company)


      When using the new TA's login to open projects worked on by the previous TA we are getting the "This application has requested the Runtime to terminate it in an unusual way" error.


      When using my login to open project there is no problem; when using the previous TA's still active login there is no problem.


      All of this might point to a permissions issue.


      I have created a copy of one of the projects and given the new TA ownership and full access permission of all the files in the folder tree, but that has made no difference.


      We started out with RH6 and tried to uninstall and reinstall it (the new TA has admin rights on the machine), but too late realised that the RH6 version was an upgrade and we can't find the RH5 serial number, so we gave ourselves 30 days grace by installing RH8 Trial, but that behaves in exactly the same way. Of course we will end up paying the 6=>8 upgrade price in 30 days, but that is our problem.


      No source code control is being used (yes I know, it will be in the future, I promise)


      The same problem occurs when loading the sample RH8 HTML projects.


      I have seen similar threads suggesting a Revo uninstall, but does that really make sense given that two out of the three previous users of the machine can still load projects?


      The usual Google searches have shown that the Visual C++ runtime can show this behaviour with a number of different applications, but the implication is that it is the parent application that is the root cause and the solution tends to be specific to them.