1 Reply Latest reply on Nov 3, 2009 6:14 PM by Sean_Wilson

    Dir 11 mis-matched to old dcr file

    djfilms9 Level 1

      SOS. I created a web site for a client 2 years ago, with quizzes in Shockwave format. Used Dir MX. All worked. Now they want upgrades to quizzes, so I revised the Dir file with Dir 11, saved as dcr file, and now client gets the error message: "The page you are trying to open contains a movie that is referenced to an incorrect version of the Shockwave player." Dir 11 on Mac does not allow you to specific the Shockwave version. The HTML code is

       

      <div id="content_lcol">

              <script type="text/javascript">

      AC_SW_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/director/sw.cab#version=3,5,0,0','width' ,'600','height','400','src','animations/quizStaff','pluginspage','http://www.macromedia.co m/shockwave/download/' ); //end AC code

      </script><noscript><object classid="clsid:166B1BCA-3F9C-11CF-8075-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/director/sw.cab" width="600" height="400">

                <param name="src" value="animations/quizStaff.dcr" />

                <embed src="animations/quizStaff.dcr" pluginspage="http://www.macromedia.com/shockwave/download/" width="600" height="400"></embed>

              </object></noscript>

      </div>

       

      I assume its the cab#version line at fault. How do I fix it to say "Shockwave version 11.5"? I tried "version=11,5,0,0", but that didn't work. I'm authoring on Mac, playing back on Windows.

       

      Any help sincerely appreciated.

       

      regards, David

        • 1. Re: Dir 11 mis-matched to old dcr file
          Sean_Wilson Adobe Community Professional

          Try:

          classid="clsid:233C1507-6A77-46A4-9443-F871F945D258"
          codebase="http://download.macromedia.com/pub/shockwave/cabs/director/sw.cab#version=11,0,0,0"
          

          I think you'll also need to specify the PlayerVersion (a new tag added to distinguish D11+ content from D10 and earlier - so that the backward compatibility player can load if required or able)

          <param name=PlayerVersion value=11>
          PlayerVersion=11