2 Replies Latest reply on Jul 15, 2008 2:09 PM by Scott McAllister

    MouseEvents Unresponsive in Windows

    Scott McAllister
      I have an application that opens with a SWFLoader playing in a panel that has a click attribute set to it. The click simply changes the state of the application. This setup works great when running the Flex app in the web browser, and when running as an AIR app on a Mac. However, when I install the AIR app onto Windows (XP or Vista), the application does not respond to any clicking.

      The window of the AIR application, which doesn't show the system chrome, is also supposed to be able to be dragged about the screen. This has the same result as the click attribute on the SWFLoader mentioned above - drags on a Mac not in Windows.

      Is there something different about programming AIR apps for Windows than for Mac?

      Thanks,
      Scott
        • 1. Re: MouseEvents Unresponsive in Windows
          ASnewbie
          Hello Scott
          Well I am unsure how you have coded the draggable area but im pretty sure you do not need to switch your code to make a drag area or anything of that sort.
          Maybe you can try to paste some code in here to give us an idea on how you are currently going about doing things but for the time being here is a short code on how I would do it :
          //make sure you get all the necessary classes, flash is smart enough to choose what it needs so use the *
          import flash.display.*;
          //dragwindow is the area which will drag the entire stage.
          dragwindow.addEventListener(MouseEvent.MOUSE_DOWN, dragWindow);
          function dragWindow(e:MouseEvent):void {
          this.stage.nativeWindow.startMove();
          }

          And that works for a sample air app i made

          Good luck!
          Murtaza Topiwalla
          • 2. Re: MouseEvents Unresponsive in Windows
            Scott McAllister Level 1
            Thanks for the response, Murtaza.

            It was actually the way I was referencing the main application from the panel with the SWFLoader. I was using parentApplication when if I changed it to parentDocument it all worked.

            It took a bit to figure out the solution, so I wrote up my findings here:

            http://blog.usu.edu/flexing/2008/07/14/oddities-with-parentapplication-in-air/

            -Scott