0 Replies Latest reply on Nov 5, 2009 8:36 AM by UbuntuPenguin

    Progress bar not appearing in datagrid

    UbuntuPenguin Level 4

      Hello everyone ,

        I have an object which has a progress bar.  I would like to represent the objects in a datagrid and show the progress bar in the datagrid.  However all I get is a blank progress bar.  I know the progress bar in the object is working because I displayed it using a repeater. Here is the offending code.

       

          <mx:DataGrid id="dataGrid" width="500" dataProvider="{model.transferCollection}" >
              <mx:columns>
                  <mx:DataGridColumn headerText="File Name" dataField="name" width="100"/>
                  <mx:DataGridColumn headerText="Size" dataField="size" width="30"/>
                  <mx:DataGridColumn headerText="Progress" dataField="progressBar" width="150">
                      <mx:itemRenderer>
                          <mx:Component>
                              <mx:HBox verticalAlign="middle">
                                  <mx:ProgressBar label="" height="6" source="{data.progressBar}"/>   
                              </mx:HBox>
                          </mx:Component>
                      </mx:itemRenderer>
                  </mx:DataGridColumn>
              </mx:columns>
          </mx:DataGrid>

       

      The objects progress bar is private , so I have a getter function called "progressBar".  Is there anyway I can make the progress bar show up.  I have tried all kinds of permutations of the "dataField" and the "source" of the <mx:ProgressBar/>" but to no avail. If I didn't explain something well enough feel free to ask , and as always points WILL be awarded !

       

      Sincerely,

        Ubu