0 Replies Latest reply on Nov 5, 2009 7:35 AM by post@jess.no

    RPC Fault - remote Object / cfc

    post@jess.no

      Hi,

       

      I have had a problem for a long time now. It happens when I  run applications from Flex Builder 3 that call remoteObjects that  again calls coldFusion cfc-files. The first time I run the applications after I have started Flex Builder, it always works ok. But after 5 - 10 minutes  of using Flex Builder without running the application in the browser… if I then run the appication, I get an error after the browser has loaded the swf-file. If I refresh the browser after the error occur , it works fine.

      This error only happens on my local coldFusion development server (built in). When I deploy the applications, everything works fine all the time.

       

      The error I get is as follows:

       

      An ActionScript error has occurred:

       

      [RPC Fault faultString="java.lang.NullPointerException" faultCode="Server.Processing" faultDetail="null"]

      at mx.rpc::AbstractInvoker/http://www.adobe.com/2006/flex/mx/internal::faultHandler()[C:\autobuild\3.2.0\frameworks\p rojects\rpc\src\mx\rpc\AbstractInvoker.as:220]

      at mx.rpc::Responder/fault()[C:\autobuild\3.2.0\frameworks\projects\rpc\src\mx\rpc\Responder .as:53]

      at mx.rpc::AsyncRequest/fault()[C:\autobuild\3.2.0\frameworks\projects\rpc\src\mx\rpc\AsyncR equest.as:103]

      at NetConnectionMessageResponder/statusHandler()[C:\autobuild\3.2.0\frameworks\projects\rpc\ src\mx\messaging\channels\NetConnectionChannel.as:569]

      at mx.messaging::MessageResponder/status()[C:\autobuild\3.2.0\frameworks\projects\rpc\src\mx \messaging\MessageResponder.as:222]

       

       

      Can anybod help me on this one?

       

      Thanks