5 Replies Latest reply on Nov 6, 2009 3:39 AM by BKBK

    Here's a fun one...

    idesdema Level 1

      Error invoking CFC.

       

      BUT IT WAS WORKING YESTERDAY!!!

       

      I'm on a Windows VPS and this morning I went onto my website to do some browsing and I get a wonderful "Error invoking CFC..." error.

       

      I have a related dropdown the uses a cfc and a bind.  It's very similar to Forta's multiple dropdown tutorial.  It has been working great for months then out of nowhere I get that error.  The first part of the cfc/bind works.  It queries the db for a list of U.S. states and returns them into the dropdown.  Ok no problem.  The second part takes the data from the first and queries the db based on the state selected.  Error time.

       

      What's worse is that the output tells me nothing.  -1?  What is -1?

       

      Here is the error: Error invoking CFC /<path_to_cfc>: -1 [Enable debugging yada yada yada]

      Page: http://www.kayakingcommunity.com/kayaking_mvc/kayaking/kayaking_waters.cfm

        • 1. Re: Here's a fun one...
          idesdema Level 1

          The error message randomly changes.  Sometimes it inserts that ugly -1, and sometimes instead of -1 it just says Internal Server Error.

           

          I had the folks on the VPS support team remove the CFIDE directory and put yesterday's version in its place and the same thing is happening.

           

          The first part of the cfc works and binds to the cfselect, once that is selected the next bind fails.

          • 2. Re: Here's a fun one...
            speedpedal Level 1

            have you checked out the logs?

             

            things to try...

             

            1. try to bind to a URL instead, and see if it works.

            2. its trying to bind to _kpcfc_select.cfc . take off the underscore ( _ ) in the filename, modify your code to point to this new cfc name and see how it goes.

             

             

            HTH.

            • 3. Re: Here's a fun one...
              idesdema Level 1

              I'll try these but it doesn't make me feel less concerned with IIS 7 and CF8.

               

              Why did this start happening when the code has been working fine?  The hosting company has made no updates to the server...

              • 4. Re: Here's a fun one...
                idesdema Level 1

                Removed the old CFIDE directory and replaced with a new one.  Used an archived version of the CFC.

                 

                Working now.

                • 5. Re: Here's a fun one...
                  BKBK Adobe Community Professional & MVP

                  What is -1?...

                  Here is the error: Error invoking CFC /<path_to_cfc>: -1 [Enable debugging yada yada yada]...

                  Sometimes it inserts that ugly -1, and sometimes instead of -1 it just says Internal Server Error.

                  Binding involves an asynchronous call. I think the -1 means that the call, hence binding, failed.