11 Replies Latest reply on Feb 9, 2009 8:55 PM by voivoed

    DW CS3 slows to crawl every few minutes

    mb1870
      Every few minutes as I am using Dreamweaver CS3 (under Vista SP1), the program becomes unresponsive and my processor maxes out (the Task Manager shows DW as hogging the CPU). I wait for what seems like minutes -- but is probably only a few seconds -- and I get control again. It happens repeatedly but I have not timed the intervals between them to see if it is a consistent time. It seems as thought Dreamweaver is busy doing something but, for the life of me, I don't know what as it happens regardless if I've made any changes to files or not -- it happens if I just sit there and watch it. Anyone else have this problem? Gord
        • 1. Re: DW CS3 slows to crawl every few minutes
          Level 7
          You using SSI files?
          I find that when I enable SSI files in DW it slows it way down.
          You might turn off that option if you are using them.


          • 2. Re: DW CS3 slows to crawl every few minutes
            Level 7
            This problem has plagued me since CS3's release. I have three different
            workstations, two on XP Pro and another with Vista and it's the same
            regardless. If you google for "dreamweaver cs3 slow" you will find lots of
            hits, especially with Macs, however I don't have a mac. There is a KB
            document that tries to blame your antivirus for scanning all the .js files
            that Dreamweaver uses making it slow, however, excluding those files from my
            resident scanner never changes anything. Also, Dreamweaver 8 runs like a
            champ and I continue to use that on each of my workstations.

            I feel rather cheated since I was really wanting to experiment with SPRY on
            CS3, however, since CS3 is such a dog, I have never had the chance. Now I'm
            looking at alternative AJAX libraries and Aptana instead. Also, they got my
            agency's money already for 5 licenses of CS3, but I never OK'd it for use by
            the rest of the web team so everyone remains on version 8.0 for now and I'm
            currently evaluating CF Eclipse as an alternative. The only thing that was
            holding me back before was I occasional use the GUI layout in DW but Eclipse
            3.4 has added that feature. I'd have stayed with DW if only CS3 worked.
            :-\

            "mb1870" <webforumsuser@macromedia.com> wrote in message
            news:g3cpii$qd3$1@forums.macromedia.com...
            > Every few minutes as I am using Dreamweaver CS3 (under Vista SP1), the
            > program
            > becomes unresponsive and my processor maxes out (the Task Manager shows DW
            > as
            > hogging the CPU). I wait for what seems like minutes -- but is probably
            > only a
            > few seconds -- and I get control again. It happens repeatedly but I have
            > not
            > timed the intervals between them to see if it is a consistent time. It
            > seems as
            > thought Dreamweaver is busy doing something but, for the life of me, I
            > don't
            > know what as it happens regardless if I've made any changes to files or
            > not --
            > it happens if I just sit there and watch it. Anyone else have this
            > problem? Gord
            >
            • 3. Re: DW CS3 slows to crawl every few minutes
              Level 7
              Where do you disable use of SSI files? I don't use any that I know of but
              if there is a setting that lets me make CS3 usable again, I'd give it a try.

              "bb" <none@none.com> wrote in message
              news:g3dqmc$47t$1@forums.macromedia.com...
              > You using SSI files?
              > I find that when I enable SSI files in DW it slows it way down.
              > You might turn off that option if you are using them.
              >
              • 4. Re: DW CS3 slows to crawl every few minutes
                mb1870 Level 1
                My site uses server-side includes. What is the option that I need to turn off for them?
                • 5. Re: DW CS3 slows to crawl every few minutes
                  Level 7


                  > My site uses server-side includes. What is the option that I need to turn off
                  > for them?
                  >

                  Are the included files the correct syntax for where they are used?
                  In other words- they are not complete html documents?

                  dw preferences->Invisible items->last choice: render included files i think.

                  --
                  Alan
                  Adobe Community Expert, dreamweaver

                  http://www.adobe.com/communities/experts/



                  • 6. Re: DW CS3 slows to crawl every few minutes
                    mb1870 Level 1
                    No, my includes are just some html, excluding the tags that would normally be at the top and bottom of a complete document.

                    I found the setting to turn off SSI display, made it and have been using DW for a short while. So far, it seems to have made something of a difference. I've had some of the slowdowns but fewer of them, and they are shorter in duration. All in all, so far, an improvement!
                    • 7. Re: DW CS3 slows to crawl every few minutes
                      Level 7
                      a tweak that might improve speed/memory is to go into preferences and back
                      down the number History "undo" steps from the default 50 to maybe 10 or 20.

                      --
                      Alan
                      Adobe Community Expert, dreamweaver

                      http://www.adobe.com/communities/experts/



                      • 8. Re: DW CS3 slows to crawl every few minutes
                        mb1870 Level 1
                        Thanks, I'll try that.
                        • 9. Re: DW CS3 slows to crawl every few minutes
                          Level 7
                          I tried this but it didn't really seem to help. The thing is still just so
                          sloooooowwwwww with all the lags and runs the CPU way up while doing
                          nothing. Also, when I try to close CS3, it sits there for like 10 or 15
                          minutes. There must be something that is causing this between all my
                          workstations, but the only real common piece of software is Office, all the
                          Adobe stuff and AVG.

                          "mb1870" <webforumsuser@macromedia.com> wrote in message
                          news:g3ehl1$j3$1@forums.macromedia.com...
                          > No, my includes are just some html, excluding the tags that would normally
                          > be
                          > at the top and bottom of a complete document.
                          >
                          > I found the setting to turn off SSI display, made it and have been using
                          > DW
                          > for a short while. So far, it seems to have made something of a
                          > difference.
                          > I've had some of the slowdowns but fewer of them, and they are shorter in
                          > duration. All in all, so far, an improvement!
                          >
                          >
                          • 10. Re: DW CS3 slows to crawl every few minutes
                            DW Hate
                            I would just like to thank DW CS3 for honing my coding skills.

                            DWCS3 was SOOO slow (on my new MacBook Pro w/4GB of ram) that I was forced to use Eclipse and NetBeans coupled with FireBug and IE toolbar.

                            I guess the only down side is that Adobe lost a customer.
                            • 11. Re: DW CS3 slows to crawl every few minutes
                              voivoed
                              I have the same problem, but it only happens when I enable file check in/check out for the site I'm working on. If that option is off, then DW works fine.

                              The only way I found to stop the slowdows is to manually click the "disconnect from server" button on the file panel. The problem is that everytime DW access the test server, I have to do that again, it's really irritating.

                              Has someone found a fix for this problem yet?