1 Reply Latest reply on Nov 10, 2009 7:27 AM by garfild100

    Getting Error using secure https, while its working with http urls

    garfild100

      Hi Helper,

       

      I am using both amf &

      amfsecure

       

      I defined my servlet-config.xml properly and also added the custom channel in my AC

       

       

      var ch1:SecureAMFChannel = new SecureAMFChannel("my-secure-amf", "https://xxxxxxx/messagebroker/amfsecure");
      var channelSet:ChannelSet = new ChannelSet();
      channelSet.addChannel(ch1);

       

      then i set this channel set to my service.

       

      When i run the application and try to access the remote service method nothing happens and after a min or so exception comes that not able to make the connection.

       

      The error:

      channelSet = (mx.messaging::ChannelSet)#6
                    clientId = (null)
                    connected = false
                    defaultHeaders = (null)
                    destination = "RFWFlexTreeTableDataService"
                    id = "0E18136A-CC9E-0C3A-7A8D-D4988264426C"
                    reconnectAttempts = 0
                    reconnectInterval = 0
                    requestTimeout = -1
                    subtopic = ""
            connected = false
            connectTimeout = -1
            enableSmallMessages = true
            endpoint = "https://xxxx/messagebroker/amfsecure"
            failoverURIs = (Array)#11
            id = "my-secure-amf"
            mpiEnabled = false
            netConnection = (flash.net::NetConnection)#12
              client = (mx.messaging.channels::SecureAMFChannel)#4
              connected = false
              objectEncoding = 3
              proxyType = "none"
              uri = "https://xxxx/messagebroker/amfsecure"
            piggybackingEnabled = false
            polling = false
            pollingEnabled = false
            pollingInterval = 3000
            protocol = "https"
            reconnecting = false
            recordMessageSizes = false
            recordMessageTimes = false

       

       

      When trying to run https://xxxx/messagebroker/amfsecure to test the messagebroker, it works fine.

      In addition,I can use normal AMFChannel and it worked fine for me to access the remote services.

       

      Only issue I am facing is with SecureAMFChannel.


      What am I doing wrong?

       

      Does using SSL related to this problem.

       

      Please please advise

       

      Thanks

       

      Jo