21 Replies Latest reply on Apr 23, 2010 8:15 AM by SalChicago

    Auto focus, iso



      I've been running AIR & apps under linux for quite a number of  months. One of my favourite applications is "tweetdeck" but since last  week the app has core dumped when started, and even after a complete  remove/cleanup/reinstall of AIR and all applications is now failing to  install.


      I'm unclear if this is an AIR problem or Tweetdeck, but it looks as  if it might be system, library incompatability so probably AIR itself.  Having said that some AIR apps are still working:



      sh-4.0# ./Adobe\ AIR\ Application\ Installer  ~/Download/TweetDeck_0_31.3.air

      Application crashed with an unhandled SIGSEGV

      Crashlog has been dumped in /tmp/airCrashLogs/1109_0938_F4htm8

        • 1. Re: Adobe AIR, linux SIGSEGV
          planetf1 Level 1

          Note the incorrect title (but no way to edit....). Browser history got the better of me (I enjoy photography!)

          EDIT: I was able to update this response not the original despite noting the error immediately. What gives?

          • 2. Re: Adobe AIR, linux SIGSEGV

            It seems to me that this is rather an Adobe Air issue, since I'm experiencing a segfault when installing ipla lite. This is on pre-release Fedora 12 x86_64. Everything worked like charm in Fedora 11 x86_64 prior to the upgrade. I tried re-installing Adobe Air, but to no avail. I have attached the crash log the program produces.

            • 3. Re: Adobe AIR, linux SIGSEGV
              planetf1 Level 1

              I'm running 32 bit x86 -- it was working fine until last week. Possibly new gtk etc libsm but hard to know what.

              • 4. Re: Adobe AIR, linux SIGSEGV
                Robert Christensen Level 2

                We are currently looking into this issue and will report back once we have more information. Thank you for letting us know.


                - Rob

                Adobe AIR Team

                • 5. Re: Adobe AIR, linux SIGSEGV
                  planetf1 Level 1


                  I did also try using "strace" to see what AIR was up to when it fails. Looks as if it might relate to some encryption settings in /etc/opt/Adobe/certificates/crypt//config.xml


                  Also looking at the core file I can see (an excerpt)



                  /opt/Adobe AIR/Versions/1.0/libCore.so(+0x2ea3ba) [0xfd03ba]

                  /opt/Adobe AIR/Versions/1.0/libCore.so(+0x2de565) [0xfc4565]


                  /usr/lib/libxml2.so.2(xmlHasProp+0x27) [0x3b8cae7]

                  /usr/lib/libxml2.so.2(xmlGetProp+0x19) [0x3b8d5f9]

                  /usr/lib/libadobecertstore.so(+0xf345) [0x5aa345]

                  /usr/lib/libadobecertstore.so(+0xf7db) [0x5aa7db]

                  /usr/lib/libadobecertstore.so(AUCS_GetCertificateList+0x29) [0x5aa727]

                  /opt/Adobe AIR/Versions/1.0/libCore.so(+0x4a937c) [0x118f37c]



                  but there's so much going on that's just a guess... can share data if required.
                  • 6. Re: Auto focus, iso

                    Can you try the following if possible:


                    1. Uninstall AIR
                    2. mv /etc/opt/Adobe/certificates/crypt /etc/opt/Adobe/certificates/crypt_bkp (you need to be root for this)
                    3. Install AIR


                    Now try installing Tweetdeck again.

                    • 7. Re: Auto focus, iso
                      planetf1 Level 1

                      That worked!


                      Adobe AIR Application Installer.swf  libCore.so

                      sh-4.0# ./Adobe\ AIR\ Application\ Installer ~/Download/TweetDeck_0_31.3.air

                      I/O warning : failed to load external entity "/etc/opt/Adobe/certificates/crypt//config.xml"

                      Unable to parse Document: /etc/opt/Adobe/certificates/crypt//config.xml.


                      So there's obviously some complaining about certificates, but tweetdeck is running.


                      Thanks for the quick helpful answer. Does this mean there's some breakage in the certificate checking (possibly after an update) or is this just cached/temporary data that needed to be cleared out?



                      • 8. Re: Auto focus, iso
                        belegdol Level 1

                        It worked - i.e. both the installation, as well as the installed application itself. Adobe Air complained about missing files, though, but I guess that's expected:


                        $ "/usr/bin/Adobe AIR Application Installer"
                        I/O warning : failed to load external entity "/etc/opt/Adobe/certificates/crypt//config.xml"
                        Unable to parse Document: /etc/opt/Adobe/certificates/crypt//config.xml.

                        • 9. Re: Auto focus, iso
                          chopr Level 1

                          Did you Uninstall AIR runtime before moving the folder ?

                          • 10. Re: Auto focus, iso
                            belegdol Level 1

                            Yes, I did. But, last time I checked, uninstalling Adobe Air via the desktop entry only removes adobeair1.0 RPM, the adobe-certs one stays intact.

                            • 11. Re: Auto focus, iso
                              chopr Level 1

                              I guess you won't see this error if you uninstall adobe-certs and then reinstall Adobe AIR runtime.

                              • 12. Re: Auto focus, iso
                                belegdol Level 1

                                Unfortunately, that got me back to square one: Adobe Air segfaults again.

                                • 13. Re: Auto focus, iso
                                  chopr Level 1

                                  Could you please send me your config.xml (found here: /etc/opt/Adobe/certificates/crypt/config.xml) to priyank.choudhury [at] adobe [dot] com


                                  This contains the hashes of the certificates that AIR installed on your machine.



                                  • 14. Re: Auto focus, iso
                                    belegdol Level 1

                                    Did you get my email? If so, have you been able to figure anything out? Thanks.

                                    Also, I installed the 2.0 beta from labs rpm (after removing both older rpms) and everything works fine now.


                                    Message was edited by: belegdol  added labs beta note

                                    • 15. Re: Adobe AIR, linux SIGSEGV
                                      belegdol Level 1

                                      The issue is still present with 1.5.3. The crypt directory rename still works the problem around.

                                      • 16. Re: Auto focus, iso

                                        After playing with aucm, I noticed that adding new certs added the <UserPreferences> tags when adding a new cert.  The config.xml from the adobe-certs package did not have this tag.  I added it to each certificate object in config.xml, for example:


                                        <certificate trustAnchor="true" trusted="true" sslServerAuth="true" codeSign="true" >
                                        <LastUpdatedBy trustAnchor="adobe" codeSign="adobe" sslServerAuth="adobe" trusted="adobe"/>


                                        That fixed all the SIGSEGV dumps. (And keeps you from getting all the unknown/unverified cert messages during application installation you get when you just rename the crypt directory.)

                                        • 17. Re: Auto focus, iso

                                          related to this:


                                          I get the same issue, but that's because I am using the SDK adl tool to run the application.


                                          So all I did was create a folder under /opt/AIR-apps/  for the application and I unziped the *.air file into a folder of its own.


                                          Then I used the command line to run it and I get stuck on this error.


                                          Should I do something extra to get these certificates 'installed'?


                                          my /etc/opt/ folder is completely empty.


                                          // Sal

                                          • 18. Re: Auto focus, iso
                                            omegabsd Level 1

                                            They get installed as part of the adobe-certs package, which is distributed with the air package.

                                            • 19. Re: Auto focus, iso
                                              SalChicago Level 1

                                              I must be missing something.


                                              You mean when one runs the application ... It should install these certs?


                                              I looked for something with 'cert' in the qsin/ folder an found nothing.  Is it because I am using this on Gentoo rather then Ubuntu or Fedora?

                                              Should I have ran some other script after unpacking the SDK and putting it on /opt/AIR-SDK/ ?  Sounds to me like that is what I missed?



                                              Bottom line: What do I do to get these certs installed on that folder ?


                                              Any help will be greatly appreciated!


                                              Thank you!

                                              • 20. Re: Auto focus, iso
                                                chopr Level 1

                                                For working with Certificates you would need to install AIR runtime on your machine, SDK is not enough. Please install the AIR runtime from: http://get.adobe.com/air/

                                                • 21. Re: Auto focus, iso
                                                  SalChicago Level 1

                                                  I did try that, but because I'm using Sabayon (a gentoo derivative) It tells me that the Installer is not supported in Non rpm or debian bases distros.


                                                  So that's why I resorted to using the SDK.  Which I can get to work for other Air apps, but not mine: qsin. This works fine in Fedora and Ubuntu.


                                                  So is there a work-around to the runtime in Gentoo/Sabayon?  Any help will be appreciated.


                                                  // Sal