5 Replies Latest reply on Dec 31, 2010 6:16 AM by AkosF

    Woes with SOAP - banging head against wall!

    mr. modus Level 1
      Please help me. I'm going nuts. I've read everything I can on the net, including this form, and just cannot get this webservice to work.

      I'm trying to set up my CF Application to work with Chase Paymentech webservices. I've tried using the XML API they have and have had no luck so thought I would try their SOAP API. The WSDL is located here:
      WSDL File

      I'm trying to use the NewOrder method.

      First I tried to use CFINVOKE. (See Code Listing 1)

      The error I get is: Web service operation "newOrder" with parameters {OrderID={sd_1},MerchantID={700000208140},IndustryType={EC},BIN={000002},ccExp={1010},tra nsType={A},ccAccountNum={5454545454545454},TerminalID={001},Amount={100}} could not be found.

      Then I read a post on this forum and tried to create the SOAP request using cfsavecontent then using cfhttp to pass it to the webservice. It appears to do nothing though since cfhttp.fileContent returns just the content of the wsdl file.
      (See code listing 2)

      I structured my SOAP request based on the example soap request in the documentation supplied by Chase.
      (See code listing 3)

      The Paymentech Integration Library can be found here:
      Integration Library

      The Webservices spec docs can be found here:
      SOAP specs

      Please note you won't be able to connect to this webservice unless your IP is registered with Chase, which is why I posted the WSDL locally on my server.

      Any help anyone can offer would be great, my forehead is getting sore and my wall is getting damaged.