2 Replies Latest reply on Nov 10, 2009 6:12 AM by dino.ap

    'Open a URL' won't work when I publish to .SWF, but works with .EXE, why?

    dino.ap

      Hi,

       

      I'm having trouble with the Open a URL or file option when I publish to .SWF.

       

      Issue: I've set the On success for a Button to the Open a URLoption, published the project to .SWF file, and the URL won't launch.

       

      Expected result: When I run the video and click on the Button, I expect to hear the "click" sound and then the URL will launch (in the existing or new window, depending on my settings).

       

      Actual result: When I run the video and click on the Button, I hear the "click" sound but the URL does NOT launch.

       

      Additional details:

      I've tried lots of different options (see below) and still can't get the URL to launch in a published .SWF. Options include:

      • Publishing the project and/or viewing the video on different machines.

      • Using the Open a URL option on:
        • Click boxes
        • Upon exiting the slide
        • Upon ending a video
      • Changing the window options (i.e., launch in New or Current window).
      • Publish to:
        • Flash 7 (see attachments for an example)
        • Flash 8
        • Flash 9
        • Flash 10

       

      I'm using Captivate 4.0.1 Build 1658 and Windows XP Pro v2002 SP3.

       

      Here's the kicker. The EXACT same project, works as expected when I publish to .EXE.

       

      Has anyone else run into this problem? If so, how do I fix it?

       

      Thanks,

      Dino