8 Replies Latest reply on Jan 26, 2010 4:11 PM by salvador_sorianojr

    Problem with .swf playback

    zombie1234

      Hello,

       

      I have a problem with .swf animation playback in captivate 4. I created the .swf in flash with as3 on one frame. The animation is contained in a movieclip. I exported from flash and made sure the framerates between captivate and flash work. I import the animation to a slide and notice that the duration of the animation is .01 (could this be a red flag?). When previewing my captivate file the animation does not play it shows up static. I have my captivate file set up with continue buttons but I tried taking the button off the animation slide and it still shows up with the static what would be animation. Has anyone else encountered this? I'm really at a loss as to whats going on

       

      For bonus points: I'm still getting a transition that fades to white briefly even after I put no transition. Is their a way to just have an abrubt transition without the fade?

       

      Cheers

       

      -Matt

        • 1. Re: Problem with .swf playback
          www.cpguru.com Level 4

          Hi Matt,

           

          Sounds to me like something is wrong with your swf. Normally when you import an swf to Captivate you get the standard 3 seconds on the timeline (unless you of course changed the defaults). What happens if you extend the playtime of your swf on the timeline in Captivate?

           

          Does your animation work when played outside of Captivate?

           

          As for your "bonus question" - The no transition seems to be bugged sometimes so you could try setting the fade in / fade out parameters to 0.0 seconds each. I usually do that when I use Widgets because even though you select no transition they will still fade in.

           

           

          /Michael

           


          Visit my Captivate blog with tips & tricks, tutorials and Widgets.

          • 2. Re: Problem with .swf playback
            zombie1234 Level 1

            Hmmm... I tried playing with the timeline on the animations slides yesterday and extending them had no effect on the animation. My flash file might be the culprit and I'm going to test a new approach. I'm using a movie clip wrapper in my flash file and inside that movieClip wrapper are other movieClips. I'm going to try and get rid of the wrapper and see if that will cause it to play out in captivate. Perhaps this might be the issue. I'll keep you guys posted.

             

            As for the slide transitions. I tried your recommendation and logically it seemed like it would work, but I'm still getting a fade effect on the background image. It seems like its shorter this time, however its still there. I just want to figure out the animation issue, I think i'll make a seperate post for the transition problem.

             

            Thanks!

             

            -Matt

            • 3. Re: Problem with .swf playback
              zombie1234 Level 1

              Also, for what its worth, i've tested the animation issue with just one slide. It will preview flawlessly and play the whole animation. When I add a slide in front of it however, thats when it won't play the whole animation.

              • 4. Re: Problem with .swf playback
                zombie1234 Level 1

                Ok, not cool. After messing with how my flash file was architected, I found a way to make it work. I de-nested all my movieclips and put them on the main timeline. It's too bad captivate can't read the movieclips as it provides for better organization in flash. This is going to take me quite a while to revise all the animations but at least now I know.

                 

                Also I think I figured out the fading. I noticed with each timeline layer you have you can set fade options for each layer. I'm still getting a fade at the beginning and end but maybe its built in that way. Hopefully this post will help save someone some time

                • 5. Re: Problem with .swf playback
                  www.cpguru.com Level 4

                  Alright now it makes more "sense".

                   

                  Your SWF problem is caused by a bug in Captivate. I have encountered this many many times. Basically if you import a Flash animation and you have more than 1 slide in Captivate it will play to the end before you get to the slide with the animation. It's a really annoying bug that also occurs if you insert an SWF created in Captivate into a master Captivate project.

                   

                  There are a couple of solutions to your problem.

                   

                  1. Try and Externalize your animations when you publish your Captivate project. This can sometimes remove the problem. You can edit the settings in Preferences - Publish Settings.

                   

                  2. Create a loader in Flash that will pull in your animation SWF. Basically you just need to do a loadMovie shell in Flash and then have that pull in your animation SWF. I use this all the time for AS2 projects, but I guess that it will work just the same for AS3 projects.

                   

                  As for your fade in / fade out issue. Did you by any chance set a transition effect on your slides? Check the Slide Properties for a transition effect. If that's not it - is your fade in issue only occuring on the first slide? The "master" setting for a Captivate project has a default to fade in on the first slide. You can change that in Preferences - Project - Start and End.

                   

                  /Michael

                   


                  Visit my Captivate blog with tips & tricks, tutorials and Widgets.

                  • 6. Re: Problem with .swf playback
                    salvador_sorianojr Level 1

                    I have applied your last suggestion, I have unchecked Fade in on the first slide, but upon launching the content it STILL Fades in on the first slide. How was that?Are there other work around to resolve this?

                    • 7. Re: Problem with .swf playback
                      Lilybiri MVP & Adobe Community Professional

                      Hello,

                       

                      Since it is the first slide, have you checked the Preferences, Project, Start and End. Maybe under Project Start Options 'Fade in on the first slide' is still activated?

                       

                      Lilybiri

                      • 8. Re: Problem with .swf playback
                        salvador_sorianojr Level 1

                        Yes I am very sure that I have disabled the Fade In on the First Slide. The bad thing is that whenever I relaunch my module it freezes, it seems whiteout/grey.