1 Reply Latest reply on Nov 19, 2009 12:28 PM by lefox

    Why do Axis Values not show up when using datavisualiation components with Runtime Share Libraries

    khanrahan

      I have developed a datavisualization flex application.  I am now trying to optimize the application and one of approaches I am trying is to use Runtime Shared Libraries.

       

      I have configured Flex Builder to deploy with Runtime Shared Libraries and have added the .swz file for the framework, datavisualization and rpc share libraries.  After deploying my application loads however my axis values within each of my charts are missing.   The axes are shown, however they do not have their label units displayed.  The series themselves are dislayed however.

       

      I have tried this using the 3.4 SDK and also the 3.2 SDK within Flex Builder.  I also tried compiling flex using the mxmlc ANT tasks and got the same results.

       

      I made sure that the framework RSL is getting loaded first and I also made sure that the global flash cache has been cleared before I tested.

       

      I can see from my access logs that the .swf files are getting loaded the first time I make a request for my application.

       

      Does anyone know why my axis values would be missing only when I deploy with RSL??? Switching back to Merged mode, my application works fine and it is only when I deploy with RSLs that I get the issue.

       

      I have also tried to compile using only the framework RSL and not the datavisualization or rpc RSLs (keeping them in merged mode) and I get the same results, no axis values.

       

      Any help is appreciated.

       

      Thanks.