1 Reply Latest reply on Nov 11, 2009 6:20 AM by tspaul

    Can't apply some master pages to topics

    tspaul Level 1



      I have already logged a bug report on this, but I am hoping that someone else has encountered it and has a suggested workaround. I have searched the forums, but I didn't see this issue. We recently upgraded to RoboHelp 8, and we have installed 8.0.1.


      Our help projects typically include multiple master pages (formerly called "templates"). Most topics use the main master page, but a few need to use one of our other master pages that is geared toward a different type of user. Most of our projects have at least 3 master pages.


      After conversion from X5 to RoboHelp 8, in some of our help projects, we cannot apply the lesser-used master pages to topics. We can right-click the topic name or within the Design window and open the Topic Properties, and we can select the correct master page, either from the drop-down list or by clicking the Browse button, and we can click Apply. Initially, the topic will show the master page as being selected; however, the header from that master page will not appear grayed out in the Design window for the topic as it should, and when you save and close the topic, the master page is no longer selected for it. This problem does not occur if I select the master page that is used for most topics; that one gets selected and applied correctly.


      This problem has happened to me and to 2 of my coworkers. I got my problem topics and templates to work, but I tried many things repeatedly and cannot pinpoint what made the problem stop happening. I am currently trying to solve the problem in a coworker's project without success.


      Things I have tried:


      1. Deleting and reimporting the master pages that are not working. (When I do this, RoboHelp crashes.)


      2. Comparing the code of the non-working master pages to the code of the master page that does work. I saw no problems.


      3. Deleting the cpd file while the project was closed and then reopening.


      4. Manually changing the tags that appear in the code of the topics to see if I can fool RoboHelp into recognizing the master page. I tried putting in the meta tag and header placeholder tags, but this did not work.


      Has anyone run into this, and if so, have you found a workaround?


      Thank you,



        • 1. Re: Can't apply some master pages to topics
          tspaul Level 1

          This was our error, not RoboHelp's. After trying several different things yesterday, I compared the code of a working master page to that of a non-working master page once again. I discovered an error in some JavaScript, and when I removed the extraneous code, the template worked. I apologize for not finding this before posting! I did try several things before I posted.