4 Replies Latest reply on Nov 15, 2009 11:07 AM by GreenFlasher

    What is the solution to "not enough memory to create sound buffer"?

    GreenFlasher Level 1

      My old computer system crashed and I replaced it with a much faster one with a lot more memory however when I open my older projects into AE CS3 on my new system I can no longer hear the audio when I render my projects via ram?

       

      I don't recall what the settings were on the old system but I didn't have this problem before and the old system was very slow compared to the new one.  My old system only had 2Gs of ram and again did not have this problem.  New new system has 12Gs ram. Even if I select a 30 second piece of video on stage it doesn't play back with audio however I see the audio levels moving.

       

      Anyone have any ideas?

       

      Thank you.

        • 1. Re: What is the solution to "not enough memory to create sound buffer"?
          Mylenium Most Valuable Participant

          Check the audio preview buffer duration in your prefs. Short of that, this may be a more generic problem with your system's audio configuration, so that is worth looking into as well.

           

          Mylenium

          1 person found this helpful
          • 2. Re: What is the solution to "not enough memory to create sound buffer"?
            GreenFlasher Level 1

            Mylenium,

             

            Thank you for responding.  I did go into the Audio Hardware settings, and in the DirectSound Output Ports I selected a device name that had a Sync Reference of No instead of the one selected Yes.  I tried a project had have sound - very happy.   I have no clue what that means.

             

            What is very strange is now that it works and I look at the same Audio Harware Settings, there are two Device names that have a Sync Reference of Yes and both of them are selected and the one that says No is not selected.  I didn't do that - have no clue what happened but I still have sound...

             

            I checked the audio preview duration and it is: 0:00 08:00.  What would you suggest it be?

             

            Thanks again for your input.

            • 3. Re: What is the solution to "not enough memory to create sound buffer"?
              Mylenium Most Valuable Participant
              I checked the audio preview duration and it is: 0:00 08:00.  What would you suggest it be?

               

              If you have sufficient RAM, you can ramp it up to 30 seconds without risk. It is in any case only relevant whzen multiple audio sources need to be "mixed", i.e. you have overlapping fades and such. With only a single source, AE will attempt audio passthrough, so disabling the sync might have freed up that part. Presumably your audio outputs are tied to another component (e.g. HDMI audio) or the audio hardware itself is set up so as to spit out surround sound or something like that, so the individual ports are synchronized by default. Turning it of simply should decouple the channels and give you a normal stereo behavior. Probably not the "clean" solution as intended by the audio hardware vendor (I'm sure you are supposed to flip some switch in their multimedia center software panel), but if it works, noone can argue success.

               

              Mylenium

              1 person found this helpful
              • 4. Re: What is the solution to "not enough memory to create sound buffer"?
                GreenFlasher Level 1

                Thanks again for the information.  Sound works and now I can get back to work...