3 Replies Latest reply on Nov 19, 2009 11:05 PM by Karlosx

    AE is clipping a fraction of a second off my imported WMV footage, how can I stop this happening?

    Karlosx

      Hi all,

       

      I've created a new composition using some WMV footage and I want to add a bit of adobe illustrator art on at the end like a closing title. I don't need to extend the length of the movie, the art can just lay over the top of the imported footage.

       

      The problem I have is when I import the footage (File > Import > File...) I import the WMV file and once inside the composition After Effects trims a tiny bit off the end of the imported footage where there's a fade to white then it ends on a black screen. It wouldn't be a problem if I wasn't losing part of someone's sentence as it fades out.

       

      Can anyone help me please?

       

      For further info, I've set fps to 25 which is the same as the imported footage and I've tried importing it into longer compositions. Oh and also if it helps I'm working on a PC using After Effects 7 Professional.

       

      I wonder if it might be something to do with the fade out in the imported footage???

       

      Many thanks in advance for any responses.

       

      KarlOSX

        • 1. Re: AE is clipping a fraction of a second off my imported WMV footage, how can I stop this happening
          Rick Gerard Adobe Community Professional & MVP

          Try converting the WMV footage to another format before you import it. Depending on the compression settings of the original file it may be a GOP compression scheme that is giving you trouble.

           

          Another option would be to try and add time remap to the clip in the timeline then extend the length of the comp and the clip wihtout moving the last keyframe.

           

          It's never a good idea to use a highly compressed source footage as the foundation of a new project. The resulting footage will be in far worse shape than the original even if the data rate is significantly higher.

          1 person found this helpful
          • 2. Re: AE is clipping a fraction of a second off my imported WMV footage, how can I stop this happening?
            Mylenium Most Valuable Participant

            The issue is most likely with the source file. The last keyframe interval is not complete and thus AE makes wrong assumptions about the clip duration because it stops at the last full keyframe. This usuall happens, if you use VBR encoding in the WMV files and leave everything at the Automatic settings. If you plan on using WMV files for your work in Ae, you should export them differentlyx from whatever otehr app you use, that is with a fixed keyframe interval and a constant data rate. As Rick said, though, re-editing already compressed files is not the best way to work, so if you have full control over the source material, consider otehr file formats, CoDecs and so on...

             

            Mylenium

            1 person found this helpful
            • 3. Re: AE is clipping a fraction of a second off my imported WMV footage, how can I stop this happening
              Karlosx Level 1

              Thanks guys,

               

              I don't have access to the original footage which is why I was working from .WMV. I normally work on a Mac so would normally avoid PC/platform specific file formats where possible. In the end I resaved the footage in another file format and reimported it into AE to work with.

               

              It worked, but as you say, there was some degradation in the quality of the image.

               

              Thanks again for the help and advice, definitely will help in the future.

               

              Karl.