0 Replies Latest reply on Nov 20, 2009 11:11 AM by tim.clearview

    Flex sporadically loses the path to a valueObject... Coldfusion Server problem

    tim.clearview

      This is a weird one... we are using Flex 2.0.1 HF3 and CFMX 7, and have code that works 99% of the time. That other 1% of the time is, of course, a problem.

       

      It seems like it only happens if we don't reboot jrun for a while, since rebooting jrun fixes the problem.

       

      The problem occurs when trying to wrote to a CF value object through a flex value object... we get:

       

      error:
      (mx.rpc::Fault)#0
        errorID = 0
        faultCode = "Server.Processing"
        faultDetail = "If the component name is specified as a type of this argument, the reason for this error might be that a definition file for such component cannot be found or is  not accessible."
        faultString = "The argument BEAN passed to function create() is not of type TestEEOCBean."
        message = "faultCode:Server.Processing faultString:'The argument BEAN passed to function create() is not of type TestEEOCBean.' faultDetail:'If the component name is specified as a type of this argument, the reason for this error might be that a definition file for such component cannot be found or is  not accessible.'"
        name = "Error"
        rootCause = (null)

       

      We've never been able to reproduce this in our dev environment, so it's nigh impossible to fix it.

       

      Any ideas, aside from restarting Coldfusion occasionally (which is not acceptable to our clients)?

       

      P.S.: Wasn't sure if this should be posted in the Flex or CF forums...