2 Replies Latest reply on Dec 8, 2009 7:25 AM by rbarthle17

    No extensions work at all, why?

    rbarthle17

      I have a CF multiserver setup with CF7, CF8, and CF9 all running on JRun. I have CFBuilder installed as plugins to a clean version of Eclipse 3.5 64-bit for OS X. I installed the basic extensions to map to the CF9 server. I also installed a couple from RIAforge, including the CFProperty Inspector.

       

      However, none of these extensions are creating the files they are supposed to. An example is the CFC Generator. I open an RDS (any of the three) and select a database table. I click to generate the CFC (or the ORM CFC just for kicks), select a directory in any of my projects, and the files are never written out.

       

      This is driving me crazy, especially since when I used this at the Chicago Flex training last week, it worked fine.

       

      Anybody have a clue why this is happening?

        • 1. Re: No extensions work at all, why?
          Ratsnackbar Level 2

          I just worked through a similar problem and thought I would share my solution but I do not know if it fits your scenario.

           

          I am using ColdFusion 9 in Multi-Server mode and Apache 2.2.x and is using Name Based VirtualHosting.  The CF installation is within a VirtualBox VM networked using bridging to my Host system where CFBuilder is installed so the result is the same as if I had a remote CF server on the same network.

           

          I installed the extensions and had the same experience as you state.  Nothing happened when I tried to use it.

           

          I found in the ColdFusion Exception log a line that stated.

          "File not found: /CFExtensions/CFCGenerator/Adobe CFC Generator/handlers/index.cfm The specific sequence of files included or processed is: \\FileHost\wwwroot\myTestSite\CFExtensions\CFCGenerator\Adobe CFC Generator\handlers\index.cfm'' "

           

          Because I am using VirtualBox and I do not want to role my Site files back with the virtual host if it is ever needed I am hosting my files out of a network share.  Thus the "\\FileHost\wwwroot" UNC in the second path.

           

          The clue however is the inclusion of the "\myTestSite" in the path which just happened to be the first VirtualHost I had set up simply to test the apache installation.  (Note: ignore the \CFExtensions\CFCGenerator portion of the path's.  That's just where I decided to put the extensions)

           

          I found that the extensions were referencing my first virtualhost listed in my Apache configs under the IP address that the server was running under.  It apparnelty was using this as the basis of the path it would use to reference it's own installed files.  If I changed that virtual host's DocumentRoot path the error changed to match it.

           

          So what I did was set up a new Name Based VirtualHost using the name of the server and pointed it to the WebRoot for it's DocumentRoot.  I placed it as the first VirtualHost in the apache configs.  (Note: as a development box security is not my primary concern here.)

           

          I also set the name of the coldfusion server in my hosts file to avoid having to put it in the DNS for the time being.

           

          After doing that everything worked.  As a side benifit it also fixed the problem I was having getting the ColdFusion Administrator to come up in my CFBuilder.

           

          I see that there is a VirtualHosts tab in the Extension setup which is likely what I should have been using all along.  Unfortunately I was not able to find any documentation in the CFBuilder Docs that specified details of how it worked and when and why to use it so I decided to ignore it for the moment and found another way.

           

          Hope that helps!

           

          -Joe

          1 person found this helpful
          • 2. Re: No extensions work at all, why?
            rbarthle17 Level 1

            Thanks for the tips. It was the virtual hosts that were causing issues. I have them all now running off of a localhost VH for my CF9 server and they all work as advertised.