4 Replies Latest reply on Feb 18, 2010 5:58 AM by Willam van Weelden

    No Nav Pane in IE 7 using RoboHelp 8

    MSMoore9412 Level 1

      There was a thread earlier about no navigation pane, but it was marked "Archived" and it looked like I couldn't reopen it -- sorry if this is a duplicate.

       

      I have a RoboHelp HTML (RoboHelp version 8) project that works fine in IE 6 and FireFox 3.5.  However, in IE 7 there is no navigation pane, which is a serious problem.  I have no idea how to debug this and would appreciate any advice about how to fix this issue.  Of course QA just discovered this today, and we're supposed to deliver the application (with Help) on Dec 4.  Thanks in advance!

        • 1. Re: No Nav Pane in IE 7 using RoboHelp 8
          MSMoore9412 Level 1

          We seem to have resolved issues with the Search functionality not working in IE7 and IE8 with RoboHelp HTML v8 WebHelp.

           

          I generated the WebHelp using the DHTML > Pure HTML setting, and a developer did the following:

           

          Added help filter to remove cache headers, so that the help files are downloaded locally when using IE.

           

          If you need more detaiI, I can ask him to provide it.

          • 2. Re: No Nav Pane in IE 7 using RoboHelp 8
            Willam van Weelden Adobe Community Professional & MVP

            Hi,

             

            I don't speak 'developer', so could you ask him exactly what caused the problem and how he solved id?

            I'd like to know, so it may save me some frustration if I come across the same problem.

             

            Greet,

             

            Willam

             

            This e-mail is personal. For our full disclaimer, please visit www.centric.eu/disclaimer.

            • 3. Re: No Nav Pane in IE 7 using RoboHelp 8
              MSMoore9412 Level 1

              Additional detail obtained from the developer:

               

              IE needs to download files locally on the browser machine when a document (aka help file) is opened.

               

              With RoboHelp, IE tries to download xml files within the whproj.xml file.  When the application server returns no-cache in the http headers, IE is not allowed to cache, and therefore does not work.  To fix the issue do the following to the response object:

               

              httpResponse.setHeader( "Cache-Control", "public" );

              httpResponse.setHeader( "Pragma", "" );

               

              We implemented that via a java filter, so that it does not interefere with the application logic.

               

              OK, so that's still developer-ese, but if you experience problems with webhelp and IE, you could send this info to your developers to have them check it out.

               

              I hope this helps.

              • 4. Re: No Nav Pane in IE 7 using RoboHelp 8
                Willam van Weelden Adobe Community Professional & MVP

                Ok, thanks.

                 

                Greet,

                 

                Willam

                 

                This e-mail is personal. For our full disclaimer, please visit www.centric.eu/disclaimer.