4 Replies Latest reply on Dec 2, 2009 1:02 PM by mhollis55

    Scanner not working in CS3 or CS4 after upgrade?

    Peakoverload Level 1

      I've been using Photoshop CS3 on my iMac pretty much since it's release and have a Canon Canonscan 4400F scanner which has always worked perfectly. However since I upgraded to Snow Leopard the scanner has been incredibly intermittent and now has finally packed up altogether but ONLY in Photoshop.


      In CS3 if I try to import from my scanner I get this errror message:


      "Cannot communicate with scanner cable may be disconnected or scanner may be turned off. Check status. Scanner driver will be closed 155.0.0"


      When I upgraded to Snow Leopard I found that the scanner didn't work at all but went to the Canon website and downloaded the latest drivers and software and that got it up and running. However I then noticed that I had to re-install the driver each time I rebooted my Mac if I wanted to use the scanner via Photoshop i.e. the Canon Toolbox software always works but the TWAIN driver seems to pack up each time in Photoshop.


      As I now have a lot of documents that I need to scan urgently yesterday I spent a number of hours trying to fix this problem as I really need to be able to scan from inside Photoshop. I once again downloaded the latest drivers and software from Canon and also downloaded the latest Canon Printer/Scanner drivers from Apple but yet again this made no difference. I then downloaded a trial version of Photoshop CS4 (and the separate TWAIN driver) and installed that. However since doing this I now cannot get my scanner to work at all in either version of Photoshop and even re-installing the latest driver from Canon won't get it working. I get the same error message saying that it cant communicate with the scanner but yet again the Canon Toolbox software DOES still work and so I can scan by using that, just not from inside Photoshop. Clearly it can't be a 'communication' problem if one program does work but another doesnt so it seems to me as though there is a problem with Photoshop CS3/CS4 under Snow Leopard with Canon scanners.


      Anyone else have this problem, anyone been able to solve it?

        • 1. Re: Scanner not working in CS3 or CS4 after upgrade?
          SuperMacGuy Level 2

          There were significant changes to plug in architecture in CS3 so many plug ins needed updated. Also the Twain drivers have changed and don't work the same. Do a search on the forum and you'll find a lot of inquiries like yours. Throwing Snow Leopard into the mix only muddles the problem more. As much as I want to like SL, it's not ready for prime time, at least not for heavy production users, IMO.

          If your stand alone app works then that's what you'll have to use. FWIW I use Viewscan now and it works fine, but yeah it's an extra step to use it.

          Sorry I can't be more helpful but I remember reading a lot of posts like this.


          • 2. Re: Scanner not working in CS3 or CS4 after upgrade?
            mhollis55 Level 4

            I have solved the problem absolutely.


            Here's the problem, but you're not going to like it much.


            Scanner companies have not continued development for their scanners for Macs. Microsoft will release significant operating system changes and the scanner makers will pop up a new driver quick as a bunny. But any change to Apple's Os is pretty much ignored by the scanner manufacturer. I bought a HP scanner just before Apple released OS X and, though they promised me OS X drivers for it, they never did the work.


            I think everyone's pretty much following HP's example here.


            I have an Epson Perfection 3170 Photo scanner. It's a good scanner, but Epson has EOLed any further upgrades to its software. I upgraded my Mac (not my operating system) from a G4-400 (sawtooth) with a 1GHz processor upgrade to a new Mac Pro. I had been running Adobe's CS3 applications on my Power PC processor but, as soon as the applications went to Intel, I couldn't scan through Photoshop.


            The problem is that the Epson Scan software is PowerPC only. You cannot use scanner software for a Universal Binary that runs Power PC only unless the Universal Binary is running on a Power PC or through Rosetta emulation on Intel. As Photoshop will choose to run using Intel-native code (it's faster), that would make it incompatible with a Universal Binary on Intel. You probably have that type of incompatibility.


            Snow Leopard is a 64-bit operating system that has some pretty clear requirements with respect to drivers. One big requirement is that applications that were written in Carbon are going to find it tough going, unless they're written using the Cocoa framework. Scanner manufacturers won't make any money off of rewriting their scanner application and Photoshop plugins for Snow Leopard. They would rather you purchase a new scanner -- then they'll make money off of that and its Snow Leopard and Intel-capable drivers.


            Currently, what I do in Leopard (I have not upgraded to Snow Leopard yet because a number of my applications will break if I do) is I use Epson's Scanner software and scan to a folder. then I drag everything into Photoshop. It's a two-step process, but it does work.


            Additionally, if your scanner's standalone software doesn't work, you can purchase Hamrick's Vuescan which does work under Snow Leopard and does work with the 4400 F (you have to have your Canon drivers installed to get it to work).


            They do offer a free trial for downloading if you want to try it out. And since they just sell software, they will upgrade it and keep it current.

            • 3. Re: Scanner not working in CS3 or CS4 after upgrade?
              Peakoverload Level 1

              Thanks for the replies, interesting and useful reading.


              The bit I don't get though is that Canon HAVE produced an updated driver for Snow Leopard and the Canon software does allow me to scan. Also Apples own Image Capture allows me to scan using this scanner so the only software that won't let me scan directly from it is Photoshop CS3 and CS4.


              Doesn't this mean that the problem isn't with the scanner or the Canon driver but with Adobe's TWAIN driver?

              • 4. Re: Scanner not working in CS3 or CS4 after upgrade?
                mhollis55 Level 4

                It's not necessarily the TWAIN driver in Photoshop. Essentially, what Photoshop does is it activates the scanner software from within the Photoshop application. It seeks the external application and has it start. All of your scanning happens in the external application. Then Photoshop tells that application to just send the image to Photoshop, not to save it to the disk.


                Hamrick's website has a very useful discussion about TWAIN and RAM usage. But that doesn't seem to point to the incompatibility issue.


                I'm betting that this whole thing boils down to 64-bit versus 32-bit. While Photoshop (even CS4) is not a 64-bit application, Snow Leopard creates a "secure" 32-bit application space for it. And that security may restrict communication between processes that derive from other applications (to prevent malware from getting in there using that as a back door). So scanner software writers would need to write some kind of a plugin that would do the message passing.


                I'm sticking to Leopard for now because I want to get my work done. I have Snow Leopard and understand it won't let me pay my bills (I use Intuit's Quicken which doesn't work under SL) or chart my income (Microsoft Office X doesn't work in SL). I also use Adobe's CS3 applications and want to wait until they come out with CS5 before I upgrade. I don't believe that CS4 applications will improve my workflow any, though others may disagree. CS3 seems to have some very serious problems running in Snow Leopard.


                And, for the nonce, I'm scanning from outside of Photoshop.