0 Replies Latest reply on Dec 5, 2009 1:19 PM by smastro

    Need help with vertical axis's and multiple lineseries

    smastro

      I am having a problem where focus is lost on one of the line series. I currently have 3 line series and 3 vertical axises. I am trying to only have either one or two vertical axis without the focus being lost.  Should I use a different type of chart or something else instead?

       

      Here is the code that I have so far.

       

       

      <mx:Stroke color="red" weight="3" id="st1"/>
          <mx:Stroke color="blue" weight="3" id="st2"/>
          <mx:Stroke color="haloorange" weight="3" id="st3"/>
         
          <mx:SeriesInterpolate id="changeEffect" duration="1000" />
         
          <mx:Text x="10" y="10" text="Select week" height="41" width="67"/>
          <mx:Text x="182" y="10" text="Select game" height="41" width="83"/>
          <mx:Text x="393" y="10" text="Select # of games" width="53" height="63"/>
          <mx:Text x="479" y="10" text="Select comparison option" height="41" width="108"/>
          <mx:Panel x="10" y="102" width="926" height="324" layout="absolute" >
             
              <mx:LineChart id="chart" width="100%" height="286"
                  showDataTips="true" fontSize="12" y="-2">   
                         
              <mx:horizontalAxis>
                 <mx:CategoryAxis id="ca1"
                      dataProvider="{teamArray}"
                      categoryField="date" />
              </mx:horizontalAxis>
             
                <mx:horizontalAxisRenderers>
                 <mx:AxisRenderer id="ar1" axis="{ca1}"/>
              </mx:horizontalAxisRenderers>
             
                <mx:verticalAxisRenderers >
                  <mx:AxisRenderer  placement="left" axis="{v1}" color="red"/>
                 
                  <mx:AxisRenderer  placement="right" axis="{v3}" color="haloorange"/>
              </mx:verticalAxisRenderers>
                        
              <mx:series>
             
                 <mx:LineSeries
                      yField="cum" id="as1"
                      lineStroke="{st1}"
                     
                       lineSegmentRenderer=
                      "mx.charts.renderers.ShadowLineRenderer">
                      <mx:verticalAxis>
                          <mx:LinearAxis id="v1"/>          
                      </mx:verticalAxis>
                     
                 </mx:LineSeries>
                                       
                  <mx:LineSeries
                      yField="cum1" id="as2"
                      lineStroke="{st2}"
                      lineSegmentRenderer=
                      "mx.charts.renderers.ShadowLineRenderer" >
                     
                     
                    
                  </mx:LineSeries> 
               
                    
                 <mx:LineSeries
                      yField="cum2" id="as3"
                      lineStroke="{st3}"
                      showDataEffect="changeEffect"
                      lineSegmentRenderer=
                      "mx.charts.renderers.ShadowLineRenderer" >
                     
                      <mx:verticalAxis>
                          <mx:LinearAxis id="v3"/>          
                      </mx:verticalAxis>
                               
                 </mx:LineSeries>