14 Replies Latest reply on Dec 8, 2009 6:24 AM by No2art

    Weird interlacing situation

    No2art

      Hi,

      i got a source video (codec: picvideo MJPEG3) to "reuse" in a new scientific presentation video.

       

      The footage is 1280x720. I normally test-view sources in VLC to see if its interlaced (with deinterlacing set to "off")

      Upon import into premiere the Video was interlaced, although it viewed fine in VLC.

       

      Premiere also interprets the video as progressive, but its clearly interlaced in the preview screen and in the export. I also have the export settings set for progressive (and 1280x720).

       

      After some hours of trying, i came to the glorious idea of testing the source in WMP. Alas, it showed up interlaced.

       

      But, when i deinterlace the footage in premiere, it looks worse than in VLC:

       

      interlacing probs.jpg

       

      So what am i doing wrong on the premiere side of things regarding the miserable quality of the deinterlacing?

        • 1. Re: Weird interlacing situation
          Colin Brougham Level 6

          Is the footage actually interlaced, then, or is it progressive and it's simply being interpreted as interlaced when you import it into Premiere? If it's the latter, you might have success reintrepreting the clip--just select the clip in the Project Panel, and go to File > Interpret Footage. Under the Field Order section, try selecting the "Conform to" radio button, and changing the option to "No Fields (Progressive Scan)". If it's the opposite, and the video should be interlaced and it's being interpreted as progressive, just do the same thing but opt for one of the interlaced choices. Be sure to match your sequence settings to your footage, as well...

           

          If I'm completely missing the boat on what you're talking about--sorry!

          • 2. Re: Weird interlacing situation
            No2art Level 1

            thank you for helping!

             

            first: i am using premiere pro cs4. so when i go to interpret footage, i dont see the options you described, i only get framerate, pixel aspect ratios and alpha channel settings???

             

            secondly: i really dont know if the footage is interlaced at this point.

            in WMP it definitely looks interlaced and in VLC it looks progressive - with deinterlacing set to "off". (see picture)

             

            however, when i rightclick on the clip and go to "field options" i can set "progressing options"

             

            NONE: looks like WMP output in the picture (middle)

            Interlace censecutive Frames: looks like WMP output (middle)

            Always Deinterlace: looks like in the picture (left side)

            Flicker removal: looks like in the picture, but a little blurrier

             

            funny thing is: in the same sequence, i use one additional clip which shows no jaggies, and a purely in premiere created sequence with a background and a title which also looks clean.

             

            but when i export, the whole video is interlaced again (i have set the export settings to progressive, btw.) ...

             

            if you are missing the boat, its because the boat is not a native english cruiser, its a little austrian rubber dinghy  ;-)

            • 3. Re: Weird interlacing situation
              Jim_Simon Level 8

              Make sure you're working in a progressive sequence.

              • 4. Re: Weird interlacing situation
                No2art Level 1

                i just checked, the sequence setting is progressive.

                • 5. Re: Weird interlacing situation
                  Colin Brougham Level 6

                  Austrian dinghy... hehe... not much use for a dinghy in a land-locked country!

                   

                  It's often difficult to find out what the field/frame settings of a particular video file are when using a software player, because they're usually designed to make the footage look "good" on a particular display--usually a computer monitor. As such, interlaced footage might be automatically deinterlaced, giving you the impression that the footage is instead progressive, when it is not. Check out either GSpot or, my preference, MediaInfo to determine (among many other things) the field order of a particular video file.

                   

                  It's curious that you don't see the Field Order options in the Interpret Footage dialog. This is what you should see:

                  interpret_footage.png

                  The default "Use Field Order from File" will usually tell you what the files are, and you can then use the "Conform to" option to change that. However, if you're not seeing those options, something odd is happening--maybe Premiere cannot determine what the files actually are? In that case, see the programs linked to above to dive into the actual details of the files. Post back when you find out more...

                   

                  EDIT: Also, what is the frame rate of the file? And can you post the details of the particular sequence preset or custom settings you're using?

                  1 person found this helpful
                  • 6. Re: Weird interlacing situation
                    No2art Level 1

                    mediainfo says interlaced, top first.

                    framerate is 29,97 (i tried to interpret it with 25, 30 or 60 to no avail, too)

                     

                    sequence settings:

                     

                    edit mode: HDV720p

                    timebase 29,97 fps

                     

                    frame size: empty

                    PAR: square

                    fields: no fields (progressive)

                    display format: 30fps drop-frame timecode

                     

                    preview file format: I-frame only MPEG

                    codec: MPEG I-Frame

                     

                    Maximum Bit Depth on

                     

                    Yeah that point is missing from my menu. Weird.

                     

                     

                    Also i still get interlaced output video from premiere although i set it to progressive.

                     

                    P.S.: what really confuses me is that VLC showed the source in "pseudoprogressive", but my output video looks interlaced in VLC.

                    • 7. Re: Weird interlacing situation
                      Colin Brougham Level 6

                      Are these files some kind of screen capture, or are they HDV? Because it would seem that if they were screen captures, they wouldn't be interlaced...

                       

                      If the footage is interlaced, and you're not mixing with other footage, you'd be best served to use a matching sequence preset, and then do your deinterlacing on export. That usually gives better results than trying to do it within a timeline. However, if you're mixing footage, you may have to do a little pre-encoding to get the files to one common format.

                      1 person found this helpful
                      • 8. Re: Weird interlacing situation
                        No2art Level 1

                        many thanks for helping.

                         

                        finally i found one culprit:

                         

                        the screencaps were progressive, but divx. They were exported to MJPEG lossless for me....

                        The picvideo compressor introduced the interlacing into the file - because for a weird reason the default setting is to use interlacing when the resolution is over a certain threshhold...

                         

                        now i transcoded that clip again explicitly without interlacing and voila, good picture in premiere preview. Even the output preview in the exporter looks fine.

                         

                        now EVERY clip used in premiere is progressive (verified with mediainfo). The sequence setting is progressive. The export settings in premiere is progressive, and so is the codec setting.

                         

                        And STILL, the exported video is interlaced again. I read that some filters in premiere introduce interlacing, but all i use at this point is

                         

                        Scale on one background bmp

                        crossfade

                        Linear wipe on a premiere title

                        Fast blur on that title

                        and opacity to fade out.

                        • 9. Re: Weird interlacing situation
                          No2art Level 1

                          i have found the root of the problem:

                           

                          the picvideo codec, working fine with vdub, seems not to work correctly with premiere.

                           

                          i exported again using no compression (my harddrive wants to say hello ;-) ) and there is no interlacing anymore.

                           

                          also, media encoder doesnt like xvid and doesnt work with divx for me.

                           

                          Its really a shame that such an expensive semi-pro application lacks in some very important features, namely exporting and interlacing.

                          • 10. Re: Weird interlacing situation
                            Harm Millaard Level 7
                            Its really a shame that such an expensive semi-pro application lacks in some very important features, namely exporting and interlacing.

                             

                            It is a shame that semi-pro editors try to edit material that is only for watching and not for editing (which is a basic mistake) and take it out on Adobe.

                             

                            It is about the same as saying: I have this omelette and I can't put it in an egg-cup. The designer of the egg-cup is at fault and should be ashamed.

                            • 11. Re: Weird interlacing situation
                              Jeff Bellune Adobe Community Professional

                              Check out either GSpot or, my preference, MediaInfo to determine (among many other things) the field order of a particular video file.

                              I use both, but I prefer GSpot just because MediaInfo incorrectly identifies the Photo-JPEG codec in .mov files as MJPEG.  I don't recall GSpot missing a proper codec identification yet.

                               

                              -Jeff

                              • 12. Re: Weird interlacing situation
                                Colin Brougham Level 6

                                I had not noticed this before, Jeff, but I just checked it and you are indeed correct. I'm going to send a note to the developer(s) about this, and I encourage you to do the same. They seem to release updates fairly regularly, so with enough clamoring, I'm sure a correction could be implemented soon.

                                 

                                They're both great tools to have in the toolbox, to the point that I'd say that either one of them is indispensible. My preference for MediaInfo comes from the shell integration--I love being able to hover over a media file and getting a quick pop-up tooltip telling me what's in the file. Good stuff...

                                • 13. Re: Weird interlacing situation
                                  Jeff Bellune Adobe Community Professional

                                  My preference for MediaInfo comes from the shell integration--I love being able to hover over a media file and getting a quick pop-up tooltip telling me what's in the file. Good stuff...

                                  That is good stuff.  And thanks for the heads-up.  I almost never use Explorer; instead I use Directory Opus.  Your tip motivated me to set up DOpus to add the Explorer infotip to my DOpus infotip display, so now I get both.  Woo-hoo!

                                   

                                  -Jeff

                                  • 14. Re: Weird interlacing situation
                                    No2art Level 1

                                     

                                     

                                    It is a shame that semi-pro editors try to edit material that is only for watching and not for editing (which is a basic mistake) and take it out on Adobe.

                                     

                                     

                                     

                                    Sometimes you just dont get anything better. And after recognising the error on my side, i prepared all material to be specifically editable.

                                     

                                    My sour grapes come mainly from exporting hassles and bad deinterlacing.

                                     

                                    P.S. I am not even semi pro, i am just beginning to work in that field, so thanks for the constructive help :-/

                                     

                                     

                                    Colin, thanks for the ride, and especially for introducing Meddiainfo to me. Very helpful tool!