0 Replies Latest reply on Dec 7, 2009 5:04 PM by TheTalkingCricket

    cfajaxproxy - Disabled?




      I'm trying to use cfajaxproxy to have a CFC dynamically generate tables and pass them back to the website. This happens on key press events to give the illusion of moving around on a map.


      I spent an hour or so typing it up. Then went to test. I was plowing through the coldfusion errors and debugging was going well until I hit a javascript error.


      "Exception thrown and not caught"


      So I looked for more help with cfajaxproxy. I have tried every single tutorial and example on the internet. Copied and pasted. They all give identicle errors. I watered down my code down to the point where it just says "howdy". But still it throws me this exception error. I had a thought that maybe my code was just fine. Maybe it was something else. So I uploaded my files to my school's coldfusion server and tested it. It worked perfectly! Aside from the minor typos that I had fixed, my code had been fine all along! It works perfectly on my school's server.


      My main question is pretty simple. Is cfajaxproxy disabled in the Developer Edition?

      What can cause it to work on a fully fledged, paid, server but not on a free, local, Dev edition, testing, server?


      Or maybe the problem has nothing to do with the version. Is there anything else I might have done wrong? I read about how you can't have html in your application.cfc. So just as a quick test I deleted my application.cfc. I still got the same error when I tested my page with the cfajaxproxy


      Thank You