1 Reply Latest reply on Dec 14, 2009 1:29 PM by cindep

    Can't control indentation in list styles

    RobWer1 Level 1

      TCS 2

      MS HTML

      Setting up a template

      Project Links to Framemaker files

      FM styles mapped to custom Robohelp styles

       

       

      I am creating a set of custom styles in my robohelp project which map to the Framemaker styles of my linked files.

      I have tried a few ways of setting up my bullets and number styles but indentation is not working the way i woud like it.

       

      1. How can i manage text wrapping?
        Wrapped text aligns with the beginning of the list item rather than the begininng of the text on the line above.
        For example, the text in this bullet point wraps and aligns with the line above, not with the bullet itself.
      2. How can the size of the FM style tab space be reduced between the number/bullet and the text, which is setup in the FM numbering section.
        How can this be reduced?

       

      I have tried to manage this by creating a custom style in the following ways without the desired results:

      • The FM style maps to an RH paragraph in which the autonumber from the FM style is used.
      • The Autonumber is not used and a bullet item is added to the RH style.
      • A mulitlevel list bullet style is set up and applied ot the RH paragraph style.
        • 1. Re: Can't control indentation in list styles
          cindep Level 1

          I don't know if what I've discovered will be of assistance to you since it isn't directly related to Framemaker, but

          I spent almost an entire day working with the new multi-list feature (which leaves much to be desired in the documentation department). It DOES work, BUT you do need to go in and modify the .css for your document.

           

          In my example, I had four levels of numbering I wanted to use. I wanted the text to wrap so it was flush with the above text, not the number/letter.This was my goal:

           

          1.  First Step (Level 1)

               A. (Level 2)

                    1. (Level 3)

                        A. (Level 4)

           

           

          Here is the multi-level part of the .css:

          rh-list.Level1 {
              x-lvl-1-type: 1;
              x-lvl-1-format: "<x>.";
              x-lvl-1-margin:  30px;
              x-lvl-1-text-indent: -26px;
              x-lvl-1-pfx-class: rls-1-Level1;
              x-lvl-2-pfx-class: rls-2-Level1;
              x-lvl-2-type: upper-alpha;
              x-lvl-2-format: "<x>.";
              x-lvl-2-margin: 64px;
              x-lvl-2-text-indent: -26px;
              x-lvl-3-type: 1;
              x-lvl-3-format: "<x>.";
              x-lvl-3-margin: 88px;
              x-lvl-3-text-indent:  -26px;
              x-lvl-3-p-tag: P;
              x-lvl-3-pfx-class: rls-3-Level1;
              x-lvl-4-type: upper-alpha;
              x-lvl-4-format: "<x>.";
              x-lvl-4-margin: 128px;
              x-lvl-4-text-indent:  -26px;
              x-lvl-4-p-tag: P;
              x-lvl-4-pfx-class: rls-4-Level1;
              x-lvl-2-p-tag: P;

           

          What I found was by setting the margin, I succeeded in moving the initial number/letter to the right; then the text-indent command takes care of the wrapping. I could not find anywhere within the multilist function to accomplish this and didn't want to have to keep moving things using the ruler (which was not always exact). Note that some of the above is already in your .css default when you create a new multi-level list. I did create a .css to make sure I wasn't messing things up.

           

          Hope this helps.

           

          Message was edited by: cindep because I figured out how to make all levels align correctly.

          1 person found this helpful